aboutsummaryrefslogtreecommitdiffstats
path: root/turkish/security
diff options
context:
space:
mode:
authorJosip Rodin <joy>2002-01-06 19:56:39 +0000
committerJosip Rodin <joy>2002-01-06 19:56:39 +0000
commit64fb0c5fd77963e7cdcb13a020d4b1da0564f774 (patch)
tree1a2982a76748ef506d6f4dca17840318c2aa723f /turkish/security
parent29128f3864574f3bbad5571da23453b027de2b82 (diff)
do the same thing like ../sitemap
CVS version numbers chinese/security/Makefile: 1.3 -> 1.4 croatian/security/Makefile: 1.10 -> 1.11 danish/security/Makefile: 1.1 -> 1.2 dutch/security/Makefile: 1.3 -> 1.4 english/security/Makefile: 1.30 -> 1.31 finnish/security/Makefile: 1.7 -> 1.8 french/security/Makefile: 1.8 -> 1.9 german/security/Makefile: 1.8 -> 1.9 hungarian/security/Makefile: 1.4 -> 1.5 italian/security/Makefile: 1.12 -> 1.13 japanese/security/Makefile: 1.9 -> 1.10 korean/security/Makefile: 1.7 -> 1.8 norwegian/security/Makefile: 1.7 -> 1.8 polish/security/Makefile: 1.1 -> 1.2 portuguese/security/Makefile: 1.1 -> 1.2 romanian/security/Makefile: 1.9 -> 1.10 russian/security/Makefile: 1.4 -> 1.5 spanish/security/Makefile: 1.8 -> 1.9 swedish/security/Makefile: 1.10 -> 1.11 turkish/security/Makefile: 1.1 -> 1.2
Diffstat (limited to 'turkish/security')
-rw-r--r--turkish/security/Makefile49
1 files changed, 45 insertions, 4 deletions
diff --git a/turkish/security/Makefile b/turkish/security/Makefile
index d256f504887..813eb8e7334 100644
--- a/turkish/security/Makefile
+++ b/turkish/security/Makefile
@@ -14,10 +14,51 @@ index.$(LANGUAGE).html: index.wml $(wildcard $(CUR_YEAR)/dsa-*.wml) \
$(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-*.data) \
$(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list.wml
-# install keys.txt
-ifeq ($(LANGUAGE),en)
+ifndef SUBLANG
+DSARDF := dsa.$(LANGUAGE).rdf
+DESTDSARDF := $(HTMLDIR)/$(DSARDF)
+else
+DSARDF := $(sort $(foreach i,$(SUBLANG),$(patsubst %.wml,%.$(LANGUAGE)-$(i).rdf,dsa.rdf)))
+DESTDSARDF := $(patsubst %.rdf,$(HTMLDIR)/%.rdf,$(DSARDF))
+endif
+
+$(DSARDF): $(ENGLISHDIR)/security/dsa.rdf.in \
+ $(wildcard $(CUR_YEAR)/dsa-*.wml) \
+ $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.wml) \
+ $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.data) \
+ $(TEMPLDIR)/recent_list.wml
+ifeq "$(LANGUAGE)" "zh"
+ $(subst :.zh,:dsa.zh,$(WML)) \
+ $(shell egrep '^-D (CUR_|CHAR)' ../.wmlrc) \
+ $(ENGLISHDIR)/security/dsa.rdf.in
+ @echo -n " * Converting: [zh_CN.GB2312], "
+ @$(B5TOGB) < dsa.zh-cn.rdf.tmp > dsa.zh-cn.rdf
+ @rm -f dsa.zh-cn.rdf.tmp
+ @$(TOCN) dsa.zh-cn.rdf
+ @echo -n "[zh_HK.Big5], "
+ @mv -f dsa.zh-hk.rdf.tmp dsa.zh-hk.rdf
+ @$(TOHK) dsa.zh-hk.rdf
+ @echo "[zh_TW.Big5]."
+ @mv -f dsa.zh-tw.rdf.tmp dsa.zh-tw.rdf
+ @$(TOTW) dsa.zh-tw.rdf
+else
+ $(WML) $(shell egrep '^-D (CUR_|CHAR)' ../.wmlrc) \
+ $(ENGLISHDIR)/security/dsa.rdf.in
+endif
+
+all:: $(DSARDF)
+
+install:: $(DESTDSARDF)
+
+$(DESTDSARDF): $(HTMLDIR)/%: %
+ install -m 664 -p $< $(HTMLDIR)
+ifeq "$(LANGUAGE)" "en"
+ ln -sf dsa.en.rdf $(HTMLDIR)/dsa.rdf
+endif
+
+ifeq "$(LANGUAGE)" "en"
install:: $(HTMLDIR)/keys.txt
-$(HTMLDIR)/keys.txt: keys.txt
- install keys.txt $(HTMLDIR)
+$(HTMLDIR)/keys.txt: $(HTMLDIR)/%: %
+ install -m 664 -p $< $(HTMLDIR)
endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy