aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/Makefile
diff options
context:
space:
mode:
authorJosip Rodin <joy>2001-05-23 23:13:10 +0000
committerJosip Rodin <joy>2001-05-23 23:13:10 +0000
commitc42c2c22f9767f1b3ef5f771568198d946e01d09 (patch)
treea34a4b55f9c8c6dff256147adf892fac3c828363 /japanese/Makefile
parent533e949d4ef433949f28cf408a2f8d3d4d28bf9b (diff)
make japanese sitemap work (ugh ugh)
CVS version numbers english/Makefile: 1.54 -> 1.55 japanese/Makefile: 1.29 -> 1.30
Diffstat (limited to 'japanese/Makefile')
-rw-r--r--japanese/Makefile27
1 files changed, 25 insertions, 2 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index ab7644c3ab6..df750e1042b 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -13,9 +13,32 @@ include $(WMLBASE)/Make.lang
ifneq "$(LANGUAGE)" "en"
sitemap.$(LANGUAGE).html: $(ENGLISHDIR)/sitemap.wml
- $(shell echo $(WML) | sed s/index/sitemap/) \
+ifeq "$(LANGUAGE)" "zh"
+ $(shell echo $(WML) | sed s/:.zh/:sitemap.zh/g) \
$(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml \
$(shell egrep '^-D (CUR_|CHAR)' .wmlrc)
+ @echo -n " * Converting: [zh_CN.GB2312], "
+ @$(B5TOGB) < sitemap.zh-cn.html.tmp > sitemap.zh-cn.html
+ @rm -f sitemap.zh-cn.html.tmp
+ @$(TOCN) sitemap.zh-cn.html
+ @echo -n "[zh_HK.Big5], "
+ @mv -f sitemap.zh-hk.html.tmp sitemap.zh-hk.html
+ @$(TOHK) sitemap.zh-hk.html
+ @echo "[zh_TW.Big5]."
+ @mv -f sitemap.zh-tw.html.tmp sitemap.zh-tw.html
+ @$(TOTW) sitemap.zh-tw.html
+else
+ifeq "$(LANGUAGE)" "ja"
+ wml -q -D CUR_YEAR=2001 -o UNDEFuJA:sitemap.ja.html.tmp@g+w \
+ --prolog="/usr/bin/kcc -e -" --epilog="./convert sitemap.ja.html" \
+ ../english/sitemap.wml \
+ -D CUR_LANG=Japanese -D CUR_ISO_LANG=ja -D CHARSET=iso-2022-jp
+else
+ $(shell sed $(WML) | sed s/index/sitemap/) \
+ $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml \
+ $(shell egrep '^-D (CUR_|CHAR)' .wmlrc)
+endif
+endif
endif
index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/mainpage.wml \
@@ -28,5 +51,5 @@ index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/mainpage.wml \
install::
test -L $(HTMLDIR)/intl || ln -sf international $(HTMLDIR)/intl
ifneq "$(LANGUAGE)" "en"
- -install -m 664 -p sitemap.$(LANGUAGE).html $(HTMLDIR)
+ -install -m 664 -p sitemap.$(LANGUAGE)*.html $(HTMLDIR)
endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy