aboutsummaryrefslogtreecommitdiffstats
path: root/japanese/Makefile
diff options
context:
space:
mode:
authorJapanese Language Team <japanese>1998-10-21 15:09:05 +0000
committerJapanese Language Team <japanese>1998-10-21 15:09:05 +0000
commit08cba4d4ce4c4f496afc216f026b99901dbfe858 (patch)
treed8ed1f599ef02c138844e9878fb350e0d19ab77a /japanese/Makefile
parent216491ba0e2b952d11550b501ada898d58d2b735 (diff)
Improved Makefiles around coding system.
CVS version numbers japanese/Make.lang: 1.1 -> 1.2 japanese/Make.templ.inc: 1.1 -> 1.2 japanese/Makefile: 1.6 -> 1.7 japanese/News/Makefile: 1.2 -> 1.3 japanese/News/1998/Makefile: 1.1 -> 1.2 japanese/distrib/Makefile: 1.1 -> 1.2
Diffstat (limited to 'japanese/Makefile')
-rw-r--r--japanese/Makefile39
1 files changed, 22 insertions, 17 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index f0e49f3d8a5..f4cab6ebf98 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -1,31 +1,36 @@
+# This Makefile should need no changes from webwml/english/Makefile
+# Please send a message to debian-www if you need to modify anything
+# so the problem can be fixed.
+
BASE=.
HTMLDIR=$(BASE)/../../debian.org
TEMPLDIR=$(BASE)/template/debian
+# Do Not modify the following line
ENGLISHSRCDIR=$(BASE)/../english
include $(BASE)/Make.lang
-WMLFILES := $(wildcard *.wml)
-HTMLFILES := $(patsubst %.wml,$(HTMLDIR)/%.html.$(LANGUAGE),$(WMLFILES))
-
-# EPILOG=--epilog=weblint
-$(HTMLDIR)/%.html.$(LANGUAGE) : %.wml $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml
- wml -q $(EPILOG) $(<F)
-all: $(HTMLFILES)
- # ( cd 2.0; $(MAKE) )
- # ( cd MailingLists; $(MAKE) )
+# Comment out any lines for which the directory doesn't exist.
+# The '#' should be after the <tab> or the following lines won't
+# execute with some versions of make
+all: $(HTMLFILES) $(JPGDEST)
+# ( cd 2.0; $(MAKE) )
+# ( cd MailingLists; $(MAKE) )
( cd News; $(MAKE) )
( cd SPI; $(MAKE) )
- # ( cd devel; $(MAKE) )
+# ( cd devel; $(MAKE) )
( cd distrib; $(MAKE) )
- # ( cd doc; $(MAKE) )
- # ( cd intro; $(MAKE) )
- # ( cd logos; $(MAKE) )
- # ( cd ports; $(MAKE) )
- # ( cd security; $(MAKE) )
+# ( cd doc; $(MAKE) )
+# ( cd intro; $(MAKE) )
+# ( cd logos; $(MAKE) )
+# ( cd ports; $(MAKE) )
+# ( cd security; $(MAKE) )
include $(BASE)/Make.templ.inc
-$(HTMLDIR)/index.html.$(LANGUAGE): index.wml $(HTMLDIR)/News/index.html.en $(TEMPLDIR)/mainpage.wml $(TEMPLDIR)/ctime.wml $(TEMPLDIR)/recent_news.wml $(TEMPLDIR)/languages.wml
- wml -q index.wml
+# Do Not modify the following line
+$(HTMLDIR)/index.html.$(LANGUAGE): index.wml \
+ $(wildcard News/1998/1998*.wml) $(TEMPLDIR)/mainpage.wml \
+ $(TEMPLDIR)/ctime.wml $(TEMPLDIR)/recent_list.wml $(TEMPLDIR)/languages.wml
+ $(WML) index.wml

© 2014-2024 Faster IT GmbH | imprint | privacy policy