aboutsummaryrefslogtreecommitdiffstats
path: root/italian/Makefile
diff options
context:
space:
mode:
authorItalian Language Team <italian>1998-08-10 22:14:42 +0000
committerItalian Language Team <italian>1998-08-10 22:14:42 +0000
commitb2f149efeec7acb3e78ed5d0b95e6ed49e9699a7 (patch)
tree630131af6e1b657302ab6d041f185274742a1579 /italian/Makefile
parentfbaf37cb8449ccc037e12799709bb8168e31d12f (diff)
Italian Version of Makefile
Add: contact.wml Giovanni Bortolozzo <borto@pluto.linux.it> CVS version numbers italian/Makefile: INITIAL -> 1.1
Diffstat (limited to 'italian/Makefile')
-rw-r--r--italian/Makefile97
1 files changed, 97 insertions, 0 deletions
diff --git a/italian/Makefile b/italian/Makefile
new file mode 100644
index 00000000000..cb9d341fc83
--- /dev/null
+++ b/italian/Makefile
@@ -0,0 +1,97 @@
+LANG=it
+HTMLDIR=../../debian.org
+TEMPLDIR=template/debian
+ENGLISHSRCDIR=../english
+# EPILOG=--epilog=weblint
+$(HTMLDIR)/%.html.$(LANG) : %.wml $(TEMPLDIR)/template.wml
+ cd $(<D) && wml $(EPILOG) $(<F)
+# cd $(<D) && wml -o $@ $(EPILOG) $(<F)
+
+# translators should comment out the line for any file they haven't translated.
+all:\
+ $(HTMLDIR)/contact.html.$(LANG) \
+# $(HTMLDIR)/developers_corner.html.$(LANG) \
+# $(HTMLDIR)/donations.html.$(LANG) \
+# $(HTMLDIR)/index.html.$(LANG) \
+# $(HTMLDIR)/license.html.$(LANG) \
+# $(HTMLDIR)/news.html.$(LANG) \
+# $(HTMLDIR)/news1997.html.$(LANG) \
+# $(HTMLDIR)/related_links.html.$(LANG) \
+# $(HTMLDIR)/social_contract.html.$(LANG) \
+# $(HTMLDIR)/sponsor.html \
+# $(HTMLDIR)/support.html.$(LANG) \
+# $(HTMLDIR)/2.0/errata.html.$(LANG) \
+# $(HTMLDIR)/2.0/2.0beta_CD.html.$(LANG) \
+# $(HTMLDIR)/2.0/HOWTO.upgrade.html.$(LANG) \
+# $(HTMLDIR)/MailingLists/debian-announce.html.$(LANG) \
+# $(HTMLDIR)/MailingLists/subscribe.html.$(LANG) \
+# $(HTMLDIR)/MailingLists/unsubscribe.html.$(LANG) \
+# $(HTMLDIR)/devel/HOWTO_translate.html.$(LANG) \
+# $(HTMLDIR)/devel/extract_key.html.$(LANG) \
+# $(HTMLDIR)/devel/help.html.$(LANG) \
+# $(HTMLDIR)/devel/incoming_mirrors.html.$(LANG) \
+# $(HTMLDIR)/devel/maintainer_contacts.html.$(LANG) \
+# $(HTMLDIR)/devel/mirror.html.$(LANG) \
+# $(HTMLDIR)/devel/mirror_submit.html.$(LANG) \
+# $(HTMLDIR)/devel/people.html.$(LANG) \
+# $(HTMLDIR)/devel/ports.html.$(LANG) \
+# $(HTMLDIR)/devel/release_info.html.$(LANG) \
+# $(HTMLDIR)/devel/rsync_examples.html.$(LANG) \
+# $(HTMLDIR)/doc/index.html.$(LANG) \
+# $(HTMLDIR)/distrib/distrib.html.$(LANG) \
+# $(HTMLDIR)/distrib/ftplist.html.$(LANG) \
+# $(HTMLDIR)/distrib/packages.html.$(LANG) \
+# $(HTMLDIR)/distrib/vendors.html.$(LANG) \
+# $(HTMLDIR)/intro/about.html.$(LANG) \
+# $(HTMLDIR)/intro/cooperation.html.$(LANG) \
+# $(HTMLDIR)/intro/license_disc.html.$(LANG) \
+# $(HTMLDIR)/intro/cn.html.$(LANG) \
+# $(HTMLDIR)/intro/free.html.$(LANG) \
+# $(HTMLDIR)/intro/why_debian.html.$(LANG) \
+# $(HTMLDIR)/logos/index.html.$(LANG) \
+# $(HTMLDIR)/security/index.html.$(LANG) \
+# $(HTMLDIR)/
+
+
+#
+# TRANSLATORS SHOULD NOT HAVE TO TOUCH ANYTHING BELOW THIS LINE
+#
+
+$(HTMLDIR)/index.html.$(LANG): index.wml news.wml $(TEMPLDIR)/mainpage.wml $(TEMPLDIR)/ctime.wml
+ wml index.wml
+
+# with no rule, the default ruleset (at the top) is used
+$(HTMLDIR)/devel/people.html.$(LANG): devel/people.wml $(ENGLISHSRCDIR)/devel/people.names
+
+
+# template dependencies
+
+template/debian/basic.wml: template/debian/navbar.wml
+ touch template/debian/basic.wml
+
+template/debian/footer.wml: template/debian/ctime.wml
+ touch template/debian/footer.wml
+
+# template/debian/languages.wml: template/debian/
+# touch template/debian/languages.wml
+
+template/debian/menubar.wml: template/debian/footer.wml
+ touch template/debian/menubar.wml
+
+# template/debian/recent_news.wml: template/debian/
+# touch template/debian/recent_news.wml
+
+# template/debian/ctime.wml: template/debian/
+# touch template/debian/ctime.wml
+
+template/debian/mainpage.wml: template/debian/basic.wml template/debian/menubar.wml
+ touch template/debian/mainpage.wml
+
+# template/debian/navbar.wml: template/debian/
+# touch template/debian/navbar.wml
+
+template/debian/template.wml: template/debian/basic.wml template/debian/footer.wml
+ touch template/debian/template.wml
+
+people: devel/people.wml
+ cd devel && wml people.wml

© 2014-2024 Faster IT GmbH | imprint | privacy policy