aboutsummaryrefslogtreecommitdiffstats
path: root/italian/Makefile
diff options
context:
space:
mode:
authorItalian Language Team <italian>2002-11-17 10:51:47 +0000
committerItalian Language Team <italian>2002-11-17 10:51:47 +0000
commit057ed6e761378eb73abcc1f3e166a00fedff7cf6 (patch)
treed6dc8ef91634d537cb0bfd2e1e0eea406ce3f141 /italian/Makefile
parent0a6f406cd3936dd88dadbcc23973847cd6cd5d52 (diff)
Copied this Makefile from the english dir and added LOCALEDIR=$(WMLBASE)/po.
CVS version numbers italian/Makefile: 1.47 -> 1.48
Diffstat (limited to 'italian/Makefile')
-rw-r--r--italian/Makefile75
1 files changed, 74 insertions, 1 deletions
diff --git a/italian/Makefile b/italian/Makefile
index 03de1f8c0f7..c70974bfe04 100644
--- a/italian/Makefile
+++ b/italian/Makefile
@@ -1 +1,74 @@
-include $(subst webwml/italian,webwml/english,$(CURDIR))/Makefile
+# This Makefile should need no changes from webwml/english/Makefile
+# Please send a message to debian-www if you need to modify anything
+# so the problem can be fixed.
+
+WMLBASE=.
+CUR_DIR=
+SUBS=Bugs CD MailingLists News Pics banners chinese consultants devel \
+distrib doc events intro international legal logos mirror misc partners \
+ports releases searchtmpl security users vote y2k
+
+all install:: install-locale
+
+include $(WMLBASE)/Make.lang
+
+ifndef SUBLANG
+SITEMAP = sitemap.$(LANGUAGE).html
+DESTSITEMAP = $(HTMLDIR)/$(SITEMAP)
+else
+SITEMAP = $(sort $(foreach i,$(SUBLANG),\
+ $(patsubst %.wml,%.$(LANGUAGE)-$(i).html,sitemap.wml)))
+DESTSITEMAP = $(patsubst %.html,$(HTMLDIR)/%.html,$(SITEMAP))
+endif
+
+index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/mainpage.wml $(GETTEXTDEP) \
+ $(wildcard News/$(CUR_YEAR)/[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/News/$(CUR_YEAR)/[0-9]*.wml) \
+ $(wildcard security/$(CUR_YEAR)/dsa-[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-[0-9]*.wml) \
+ $(TEMPLDIR)/ctime.wml $(TEMPLDIR)/recent_list.wml $(TEMPLDIR)/languages.wml \
+ $(ENGLISHSRCDIR)/releases/info
+ $(WML) index.wml
+
+$(SITEMAP): $(ENGLISHDIR)/sitemap.wml $(TEMPLDIR)/card.wml \
+ $(TEMPLDIR)/links.tags.wml $(TEMPLDIR)/template.wml $(GETTEXTDEP) \
+ $(ENGLISHDIR)/releases/info $(ENGLISHDIR)/MailingLists/mklist.tags
+ifeq "$(LANGUAGE)" "zh"
+ $(subst :.zh,:sitemap.zh,$(WML)) \
+ $(shell egrep '^-D (CUR_|CHAR)' .wmlrc) \
+ $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml
+ @echo -n " * Converting: [zh_CN.GB2312], "
+ @$(B5TOGB) < sitemap.zh-cn.html.tmp > sitemap.zh-cn.html
+ @rm -f sitemap.zh-cn.html.tmp
+ @$(TOCN) sitemap.zh-cn.html
+ @echo -n "[zh_HK.Big5], "
+ @mv -f sitemap.zh-hk.html.tmp sitemap.zh-hk.html
+ @$(TOHK) sitemap.zh-hk.html
+ @echo "[zh_TW.Big5]."
+ @mv -f sitemap.zh-tw.html.tmp sitemap.zh-tw.html
+ @$(TOTW) sitemap.zh-tw.html
+else
+ $(WML) $(shell egrep '^-D (CUR_|CHAR)' .wmlrc) \
+ $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml
+endif
+
+ifneq "$(LANGUAGE)" "en"
+LOCALEDIR=$(WMLBASE)/po
+contact.$(LANGUAGE).html : contact.wml $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc \
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml $(LOCALEDIR)/others.mo
+endif
+
+all:: $(SITEMAP)
+
+install:: $(DESTSITEMAP)
+ifeq "$(LANGUAGE)" "en"
+ test -L $(HTMLDIR)/intl || ln -sf international $(HTMLDIR)/intl
+ test -L $(HTMLDIR)/mirrors || ln -sf mirror $(HTMLDIR)/mirrors
+
+install:: $(HTMLDIR)/favicon.ico
+
+$(HTMLDIR)/favicon.ico: favicon.ico
+ install -p -m 664 favicon.ico $(HTMLDIR)
+endif
+
+install-locale:
+ $(MAKE) -C po install
+

© 2014-2024 Faster IT GmbH | imprint | privacy policy