aboutsummaryrefslogtreecommitdiffstats
path: root/french/Makefile
diff options
context:
space:
mode:
authorChristophe Le Bars <clebars>1998-07-22 01:33:40 +0000
committerChristophe Le Bars <clebars>1998-07-22 01:33:40 +0000
commit889224319bc7c83f85f3402b96cbfdb927e0e958 (patch)
treeb4deb7e83e6f572d52b0fbd911aee471fc57242e /french/Makefile
parentebc029728c6970b87843dbf0a35dfe8258c5c84c (diff)
Christophe Le Bars <clebars@debian.org>
Initialize the french directory CVS version numbers french/Makefile: INITIAL -> 1.1 french/social_contract.wml: INITIAL -> 1.1
Diffstat (limited to 'french/Makefile')
-rw-r--r--french/Makefile93
1 files changed, 93 insertions, 0 deletions
diff --git a/french/Makefile b/french/Makefile
new file mode 100644
index 00000000000..b99339eb8dd
--- /dev/null
+++ b/french/Makefile
@@ -0,0 +1,93 @@
+LANG=fr
+HTMLDIR=../../debian.org
+TEMPLDIR=template/debian
+ENGLISHSRCDIR=../english
+# EPILOG=--epilog=weblint
+$(HTMLDIR)/%.html.$(LANG) : %.wml $(TEMPLDIR)/template.wml
+ cd $(<D) && wml $(EPILOG) $(<F)
+# cd $(<D) && wml -o $@ $(EPILOG) $(<F)
+
+# translators should comment out the line for any file they haven't translated.
+all:\
+ $(HTMLDIR)/social_contract.html.$(LANG) \
+ #$(HTMLDIR)/contact.html.$(LANG) \
+ #$(HTMLDIR)/developers_corner.html.$(LANG) \
+ #$(HTMLDIR)/donations.html.$(LANG) \
+ #$(HTMLDIR)/index.html.$(LANG) \
+ #$(HTMLDIR)/license.html.$(LANG) \
+ #$(HTMLDIR)/news.html.$(LANG) \
+ #$(HTMLDIR)/news1997.html.$(LANG) \
+ #$(HTMLDIR)/related_links.html.$(LANG) \
+ #$(HTMLDIR)/sponsor.html \
+ #$(HTMLDIR)/support.html.$(LANG) \
+ #$(HTMLDIR)/2.0/2.0beta_CD.html.$(LANG) \
+ #$(HTMLDIR)/MailingLists/debian-announce.html.$(LANG) \
+ #$(HTMLDIR)/MailingLists/subscribe.html.$(LANG) \
+ #$(HTMLDIR)/MailingLists/unsubscribe.html.$(LANG) \
+ #$(HTMLDIR)/devel/extract_key.html.$(LANG) \
+ #$(HTMLDIR)/devel/people.html.$(LANG) \
+ #$(HTMLDIR)/devel/help.html.$(LANG) \
+ #$(HTMLDIR)/devel/ports.html.$(LANG) \
+ #$(HTMLDIR)/devel/incoming_mirrors.html.$(LANG) \
+ #$(HTMLDIR)/devel/release_info.html.$(LANG) \
+ #$(HTMLDIR)/devel/maintainer_contacts.html.$(LANG) \
+ #$(HTMLDIR)/devel/rsync_examples.html.$(LANG) \
+ #$(HTMLDIR)/devel/mirror.html.$(LANG) \
+ #$(HTMLDIR)/doc/index.html.$(LANG) \
+ #$(HTMLDIR)/distrib/distrib.html.$(LANG) \
+ #$(HTMLDIR)/distrib/ftplist.html.$(LANG) \
+ #$(HTMLDIR)/distrib/packages.html.$(LANG) \
+ #$(HTMLDIR)/distrib/vendors.html.$(LANG) \
+ #$(HTMLDIR)/intro/about.html.$(LANG) \
+ #$(HTMLDIR)/intro/cooperation.html.$(LANG) \
+ #$(HTMLDIR)/intro/license_disc.html.$(LANG) \
+ #$(HTMLDIR)/intro/cn.html.$(LANG) \
+ #$(HTMLDIR)/intro/free.html.$(LANG) \
+ #$(HTMLDIR)/intro/why_debian.html.$(LANG) \
+ #$(HTMLDIR)/logos/index.html.$(LANG) \
+ #$(HTMLDIR)/security/index.html.$(LANG) \
+ $(HTMLDIR)/
+
+
+#
+# TRANSLATORS SHOULD NOT HAVE TO TOUCH ANYTHING BELOW THIS LINE
+#
+
+$(HTMLDIR)/index.html.$(LANG): index.wml news.wml $(TEMPLDIR)/mainpage.wml $(TEMPLDIR)/ctime.wml
+ wml index.wml
+
+# with no rule, the default ruleset (at the top) is used
+$(HTMLDIR)/devel/people.html.$(LANG): devel/people.wml $(ENGLISHSRCDIR)/devel/people.names
+
+
+# template dependencies
+
+template/debian/basic.wml: template/debian/navbar.wml
+ touch template/debian/basic.wml
+
+template/debian/footer.wml: template/debian/ctime.wml
+ touch template/debian/footer.wml
+
+# template/debian/languages.wml: template/debian/
+# touch template/debian/languages.wml
+
+template/debian/menubar.wml: template/debian/footer.wml
+ touch template/debian/menubar.wml
+
+# template/debian/recent_news.wml: template/debian/
+# touch template/debian/recent_news.wml
+
+# template/debian/ctime.wml: template/debian/
+# touch template/debian/ctime.wml
+
+template/debian/mainpage.wml: template/debian/basic.wml template/debian/menubar.wml
+ touch template/debian/mainpage.wml
+
+# template/debian/navbar.wml: template/debian/
+# touch template/debian/navbar.wml
+
+template/debian/template.wml: template/debian/basic.wml template/debian/footer.wml
+ touch template/debian/template.wml
+
+people: devel/people.wml
+ cd devel && wml people.wml

© 2014-2024 Faster IT GmbH | imprint | privacy policy