aboutsummaryrefslogtreecommitdiffstats
path: root/english
diff options
context:
space:
mode:
authorKurt Roeckx <kurt@roeckx.be>2024-03-02 22:57:19 +0100
committerKurt Roeckx <kurt@roeckx.be>2024-03-02 22:57:19 +0100
commitf7a2c7fdce0129493fe6564197aba856d9a7c31d (patch)
tree81d0e7c2e80f6728348040361c68461a1f4deafd /english
parent6239d9eb92bf2d6fc7f80fcd70b2de8493e207f9 (diff)
Add DPL 2024 election page
Diffstat (limited to 'english')
-rw-r--r--english/vote/2024/Makefile68
-rw-r--r--english/vote/2024/index.wml7
-rw-r--r--english/vote/2024/vote_001.wml112
3 files changed, 187 insertions, 0 deletions
diff --git a/english/vote/2024/Makefile b/english/vote/2024/Makefile
new file mode 100644
index 00000000000..50a0791aa6f
--- /dev/null
+++ b/english/vote/2024/Makefile
@@ -0,0 +1,68 @@
+# If this makefile is not generic enough to support a translation,
+# please contact debian-www.
+
+WMLBASE=../..
+CUR_DIR=vote/2023
+SUBS=platforms
+VOTE=$(basename $(sort $(wildcard vote_*.wml)))
+
+include $(WMLBASE)/Make.lang
+
+
+$(foreach i, $(VOTE), $(i).$(LANGUAGE).html): %.$(LANGUAGE).html: %.wml \
+ $(sort $(wildcard $(ENGLISHSRCDIR)/$(CUR_DIR)/../[0-9]*/vote_*.wml)) \
+ $(sort $(wildcard vote_*_quorum.txt)) $(sort $(wildcard vote_*_quorum.src)) \
+ $(sort $(wildcard vote_*_majority.txt)) $(sort $(wildcard vote_*_majority.src)) \
+ $(sort $(wildcard vote_*_results.src)) \
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/votebar.wml
+ $(WML) $(<F)
+index.$(LANGUAGE).html: index.wml $(sort $(wildcard vote_*.wml)) \
+ $(sort $(wildcard $(ENGLISHSRCDIR)/$(CUR_DIR)/../[0-9]*/vote_*.wml)) \
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list.wml \
+ $(TEMPLDIR)/votebar.wml
+
+$(foreach i, $(basename $(sort $(wildcard suppl_*_stats.wml))), $(i).$(LANGUAGE).html): \
+%.$(LANGUAGE).html: %.wml $(sort $(wildcard vote_*_index.src))
+ $(WML) $(<F)
+
+ifeq "$(LANGUAGE)" "en"
+
+textfiles :=
+# vote_001_quorum.log \
+# vote_001_tally.txt vote_001_voters.txt \
+# vote_001_results.dot vote_001_results.txt \
+# vote_001_results.png vote_001_quorum.txt \
+# vote_001_vote.png \
+# vote_001_vote_detailed.png \
+# vote_002_quorum.log vote_002_quorum.txt \
+# vote_002_tally.txt vote_002_voters.txt \
+# vote_002_vote.png vote_002_results.png \
+# vote_002_results.dot vote_002_results.txt \
+# vote_002_vote_detailed.png \
+# vote_003_quorum.log vote_003_quorum.txt \
+# vote_003_tally.txt vote_003_voters.txt \
+# vote_003_vote.png vote_003_results.png \
+# vote_003_results.dot vote_003_results.txt \
+# vote_003_vote_detailed.png
+
+
+
+desttextfiles := $(patsubst %,$(HTMLDIR)/%,$(textfiles))
+
+install:: $(desttextfiles)
+
+$(desttextfiles): $(HTMLDIR)/%: %
+ @test -d $(HTMLDIR) || mkdir -m g+w -p $(HTMLDIR)
+ install -m 664 -p $< $(HTMLDIR)
+
+
+cleandest::
+ rm -f $(desttextfiles)
+endif
+
+check:
+ for i in $(sort $(wildcard *.$(LANGUAGE).html)); do \
+ echo $$i; \
+ onsgmls -e -g -s -u /usr/share/sgml/declaration/html.decl $$i; \
+ echo $$i done; \
+ done
diff --git a/english/vote/2024/index.wml b/english/vote/2024/index.wml
new file mode 100644
index 00000000000..cd849d42183
--- /dev/null
+++ b/english/vote/2024/index.wml
@@ -0,0 +1,7 @@
+<define-tag pagetitle>Issues brought up in 2024</define-tag>
+#use wml::debian::template title="<pagetitle>" NOHEADER="true"
+#use wml::debian::votebar
+#use wml::debian::recent_list
+
+<h1><pagetitle></h1>
+<:= get_recent_list('.', '0', '$(ENGLISHDIR)/vote/2024', 'list', 'vote_\d*') :>
diff --git a/english/vote/2024/vote_001.wml b/english/vote/2024/vote_001.wml
new file mode 100644
index 00000000000..503d16910ed
--- /dev/null
+++ b/english/vote/2024/vote_001.wml
@@ -0,0 +1,112 @@
+<define-tag pagetitle>Debian Project Leader Elections 2024</define-tag>
+<define-tag status>P</define-tag>
+# meanings of the <status> tag:
+# P: proposed
+# D: discussed
+# V: voted on
+# F: finished
+# O: other (or just write anything else)
+
+#use wml::debian::template title="<pagetitle>" BARETITLE="true" NOHEADER="true"
+#use wml::debian::toc
+#use wml::debian::votebar
+
+
+ <h1><pagetitle></h1>
+ <toc-display />
+
+
+
+# The Tags beginning with v are will become H3 headings and are defined in
+# english/template/debian/votebar.wml
+# all possible Tags:
+
+# vdate, vtimeline, vnominations, vdebate, vplatforms,
+# Proposers
+# vproposer, vproposera, vproposerb, vproposerc, vproposerd,
+# vproposere, vproposerf
+# Seconds
+# vseconds, vsecondsa, vsecondsb, vsecondsc, vsecondsd, vsecondse,
+# vsecondsf, vopposition
+# vtext, vtextb, vtextc, vtextd, vtexte, vtextf
+# vchoices
+# vamendments, vamendmentproposer, vamendmentseconds, vamendmenttext
+# vproceedings, vmajorityreq, vstatistics, vquorum, vmindiscuss,
+# vballot, vforum, voutcome
+
+
+ <vtimeline />
+ <table class="vote">
+ <tr>
+ <th>Nomination period:</th>
+ <td>Saturday 2024-03-09 00:00:00 UTC</td>
+ <td>Friday 2024-03-15 23:59:59 UTC</td>
+ </tr>
+ <tr>
+ <th>Campaigning period:</th>
+ <td>Saturday 2024-03-16 00:00:00 UTC</td>
+ <td>Friday 2024-04-05 23:59:59 UTC</td>
+ </tr>
+ <tr>
+ <th>Voting period:</th>
+ <td>Saturday 2024-04-06 00:00:00 UTC</td>
+ <td>Friday 2024-04-19 23:59:59 UTC</td>
+ </tr>
+ </table>
+ <p>Please note that the new term for the project leader shall start on 2024-04-21.</p>
+
+# <vnominations />
+# <ol>
+# <li>Jonathan Carter [<email jcc@debian.org>] [<a href='https://lists.debian.org/debian-vote/2024/03/msg00002.html'>nomination mail</a>] [<a href="platforms/jcc">platform</a>]
+# </ol>
+
+# <p>
+# The ballot, when ready, can be requested through email
+# by sending a signed email to
+# <a href="mailto:ballot@vote.debian.org">ballot@vote.debian.org</a>
+# with the subject leader2024.
+# </p>
+
+# <vstatistics />
+# <p>
+# This year, like always,
+## <a href="https://vote.debian.org/~secretary/leader2024/">statistics</a>
+# <a href="suppl_001_stats">statistics</a>
+# will be gathered about ballots received and
+# acknowledgements sent periodically during the voting period.
+# Additionally, the list of <a href="vote_001_voters.txt">voters</a> will be recorded.
+# Also, the <a href="vote_001_tally.txt">tally
+# sheet</a> will also be made available to be viewed.
+# Please remember that the project leader election has a
+# secret ballot, so the tally sheet will not contain the
+# voter's name but a HMAC that allows the voters to check
+# that their vote is in the list of votes. There is a
+# key generated for each voter that is send along with
+# the ack for the vote.
+# </p>
+
+
+# <vquorum />
+# <p>
+# With the current list of <a href="vote_001_quorum.log">voting
+# developers</a>, we have:
+# </p>
+# <pre>
+##include 'vote_001_quorum.txt'
+# </pre>
+##include 'vote_001_quorum.src'
+#
+#
+# <vmajorityreq />
+# <p>The candidates need a simple majority to be eligible.</p>
+#
+##include 'vote_001_majority.src'
+#
+#
+# <voutcome />
+##include 'vote_001_results.src'
+#
+ <hrline>
+ <address>
+ <a href="mailto:secretary@debian.org">Debian Project Secretary</a>
+ </address>

© 2014-2024 Faster IT GmbH | imprint | privacy policy