aboutsummaryrefslogtreecommitdiffstats
path: root/english/women
diff options
context:
space:
mode:
authorSteve McIntyre <steve@einval.com>2018-06-06 02:14:55 +0100
committerSteve McIntyre <steve@einval.com>2018-06-06 02:20:41 +0100
commit533db96be6c6b97b4bf26203b429f24b2ad56cb4 (patch)
treeb826f626f219ceeedbfadf2c8f14f6811aa89448 /english/women
parentf035d5bf50874ad2e3c2b25aefcac111b4c5cbb0 (diff)
Major Makefile overhauls
Add rules to generate the git revs cache in Makefile.common, referenced as $(VCSREVCACHE) Add an extra order-only prerequisite on $(VCSREVCACHE) for ~all rules converting .wml to .html, so that we'll make sure we have a cache built up-front before we start building anything. More factorisation of various year-based Makefiles to use a common Make.year set of rules.
Diffstat (limited to 'english/women')
-rw-r--r--english/women/profiles/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/english/women/profiles/Makefile b/english/women/profiles/Makefile
index 9d7cdf188d9..1c98a114684 100644
--- a/english/women/profiles/Makefile
+++ b/english/women/profiles/Makefile
@@ -10,10 +10,14 @@ PROFILES := $(filter-out index.wml, $(wildcard *.wml))
NOGENERICDEP := true
include $(WMLBASE)/Make.lang
+# The "| $(VCSREVCACHE)" here is an order-only prerequisite - always
+# check that the prerequisite exists and is up to date, but don't
+# rebuild everything whenever it's updated - see
+# https://www.gnu.org/software/make/manual/html_node/Prerequisite-Types.html
index.$(LANGUAGE).html : index.wml $(WMLRCDEP) $(GETTEXTDEP) \
$(PROFILES) \
$(TEMPLDIR)/users_list.wml \
- $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml | $(VCSREVCACHE)
$(WML) $(<F)
ifeq "$(LANGUAGE)" "en"
-$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
@@ -27,7 +31,7 @@ endif
$(ENGLISHSRCDIR)/women/profiles/profiles.def \
$(TEMPLDIR)/faqs.wml \
$(TEMPLDIR)/profiles.wml \
- $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml | $(VCSREVCACHE)
$(WML) $(<F)
ifeq "$(LANGUAGE)" "en"
-$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)

© 2014-2024 Faster IT GmbH | imprint | privacy policy