aboutsummaryrefslogtreecommitdiffstats
path: root/english/women
diff options
context:
space:
mode:
authorSteve McIntyre <steve@einval.com>2018-06-10 19:30:04 +0100
committerSteve McIntyre <steve@einval.com>2018-06-10 19:30:04 +0100
commit1714c6efd98fafeddf5189f68841acfcca607b3b (patch)
tree8aeaab41ef14faa7d05125dba149e502f3a665b2 /english/women
parent03bccc276e67c0a9fb10424a55133b33421231f2 (diff)
Add an option to stop make on various errors
By default, many of the processes in the webwml build are run with a leading "-" so that make will ignore errors. Replace *most* of those (*not* including rm calls for make clean) with $(IGNORE) and add a conditional to Makefile.common to control what $(IGNORE) does. By default, things will work just the same as before. If you set STRICT_ERROR_CHECKS=1 in Makefile.common, the build will now be much more strict. Most people can just ignore the change to add this option, but it's helpful when debugging the scripts to have things fail cleanly and quickly.
Diffstat (limited to 'english/women')
-rw-r--r--english/women/profiles/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/english/women/profiles/Makefile b/english/women/profiles/Makefile
index 1c98a114684..a68a805a9ca 100644
--- a/english/women/profiles/Makefile
+++ b/english/women/profiles/Makefile
@@ -20,10 +20,10 @@ index.$(LANGUAGE).html : index.wml $(WMLRCDEP) $(GETTEXTDEP) \
$(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml | $(VCSREVCACHE)
$(WML) $(<F)
ifeq "$(LANGUAGE)" "en"
- -$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
+ $(IGNORE)$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
else
ifneq "$(findstring international,$(CUR_DIR))" ""
- -$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
+ $(IGNORE)$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
endif
endif
@@ -34,9 +34,9 @@ endif
$(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml | $(VCSREVCACHE)
$(WML) $(<F)
ifeq "$(LANGUAGE)" "en"
- -$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
+ $(IGNORE)$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
else
ifneq "$(findstring international,$(CUR_DIR))" ""
- -$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
+ $(IGNORE)$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
endif
endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy