aboutsummaryrefslogtreecommitdiffstats
path: root/english/template/debian/projectnews
diff options
context:
space:
mode:
authorFrancesca Ciceri <madamezou>2012-03-16 17:37:09 +0000
committerFrancesca Ciceri <madamezou>2012-03-16 17:37:09 +0000
commited354bd91b6ab1abddca746962ab913262c2387a (patch)
tree5dfd60de3579dfe210e39a4470b862f6c30b4709 /english/template/debian/projectnews
parent19d183c8d75e407e18140b265b79a4e4b185d0d6 (diff)
[en] boilerplates for DPN, see <20120229151617.GB16308@zouish.org> and <87k434i1do.wl%i38w7i3@yahoo.co.jp>
CVS version numbers english/News/weekly/Makefile: 1.55 -> 1.56 english/po/Makefile: 1.92 -> 1.93 english/po/newsevents.pot: 1.6 -> 1.7 english/template/debian/projectnews/boilerplates.wml: INITIAL -> 1.1
Diffstat (limited to 'english/template/debian/projectnews')
-rw-r--r--english/template/debian/projectnews/boilerplates.wml94
1 files changed, 94 insertions, 0 deletions
diff --git a/english/template/debian/projectnews/boilerplates.wml b/english/template/debian/projectnews/boilerplates.wml
new file mode 100644
index 00000000000..94f9cde738a
--- /dev/null
+++ b/english/template/debian/projectnews/boilerplates.wml
@@ -0,0 +1,94 @@
+#use wml::debian::common_tags
+
+
+### TODO:
+# "interviews": text changes in case of 1 or more interviews
+#
+# "events": need to add a list of events inside to block of standard
+# (and gettextized) text
+#
+# "newcontributors": 3 vars (dd, dm, uploader) + if one of them ==0 just
+# skip it
+#
+# "dsa": 3 tags (dsa, stable announce, bpo announce) each one with own
+# list, inside 2 blocks of gettextized text + if one is not added just
+# skip it
+#
+# "nnwp": gettextized block + list
+#
+#
+#
+
+
+
+# here the only variable is the number (expressed in letters) of the issue, there's probably a
+# smarter way to do it, but for now this one works.
+# example:
+# <intro issue="fourth" /> please remember that the the var issue is not
+# localized so the translators needs to put it in directly in their
+# language
+
+<bind-gettext-domain domain="newsevents" />
+<define-tag intro>
+<preserve issue />
+<set-var %attributes />
+<p><gettext domain="newsevents">Welcome to this year's <get-var issue /> issue of DPN, the newsletter for the Debian community. Topics covered in this issue include:</gettext></p>
+<restore issue />
+</define-tag>
+
+## rc-paragraph. We have three different vars:
+# release: is the codename for the current testing
+# testing: is the number of bugs as defined by this UDD query →
+# http://udd.debian.org/bugs.cgi?release=wheezy_and_sid&patch=&pending=&security=&wontfix=&upstream=&unreproducible=&forwarded=&claimed=&deferred=&notmain=&notwheezy=&base=&standard=&merged=&done=&outdatedwheezy=&outdatedsid=&needmig=&newerubuntu=&fnewer=&fnewerval=7&rc=1&sortby=source&sorto=asc&cpopcon=1&cseverity=1&ctags=1
+# tobefixed: is the number of bugs as defined by this UDD query →
+# http://udd.debian.org/bugs.cgi?release=wheezy_and_sid&patch=ign&pending=ign&security=ign&wontfix=&upstream=&unreproducible=&forwarded=&claimed=ign&deferred=ign&notmain=ign&notwheezy=&base=&standard=&merged=ign&done=ign&outdatedwheezy=&outdatedsid=&needmig=&newerubuntu=&fnewer=&fnewerval=7&rc=1&sortby=source&sorto=asc&cpopcon=1&cseverity=1&ctags=1
+#
+# example:
+# <rcstats release="Wheezy"
+# testing="613"
+# tobefixed="410" />
+
+<define-tag rcstats>
+<preserve release />
+<preserve testing />
+<preserve tobefixed />
+<set-var %attributes />
+<p><gettext domain="newsevents">According to the <a href="http://udd.debian.org/bugs.cgi">Bugs Search interface of the Ultimate Debian Database</a>, the upcoming release, Debian <q><get-var release /></q>, is currently affected by <get-var testing /> Release-Critical bugs. Ignoring bugs which are easily solved or on the way to being solved, roughly speaking, about <get-var tobefixed /> Release-Critical bugs remain to be solved for the release to happen.</gettext></p>
+<p><gettext domain="newsevents">There are also some <a href="http://wiki.debian.org/ProjectNews/RC-Stats">hints on how to interpret</a> these numbers.</gettext></p>
+<restore release />
+<restore testing />
+<restore tobefixed />
+</define-tag>
+
+## this one regards wnpp, and variables are:
+# link: link to the mail report from wnnp@debian.org to
+# debian-devel@lists.debian.org for the current week
+#
+# orphaned: the number of packages orphaned according to $link
+# rfa: the number of packages up for adoption according to $link
+#
+# example:
+# <wnpp link="http://http://lists.debian.org/debian-devel/2012/02/msg00710.html"
+# orphaned="409"
+# rfa="142" />
+
+<define-tag wnpp>
+<preserve link />
+<preserve orphaned />
+<preserve rfa />
+<set-var %attributes />
+<p><gettext domain="newsevents"><a href="<get-var link />">Currently</a> <a href="m4_DEVEL/wnpp/orphaned"><get-var orphaned /> packages are orphaned</a> and <a href="m4_DEVEL/wnpp/rfa"><get-var rfa /> packages are up for adoption</a>: please visit the complete list of <a href="m4_DEVEL/wnpp/help_requested">packages which need your help</a>.</gettext></p>
+<restore link />
+<restore orphaned />
+<restore rfa />
+</define-tag>
+
+# this is the final paragraph: no vars in here, you just need to put the
+# tag as it is at the end of the file (just before the editor line)
+# example:
+# <continue-dpn />
+
+<define-tag continue-dpn>
+<p><gettext domain="newsevents">Please help us create this newsletter. We still need more volunteer writers to watch the Debian community and report about what is going on. Please see the <a href="http://wiki.debian.org/ProjectNews/HowToContribute">contributing page</a> to find out how to help. We're looking forward to receiving your mail at <a href="mailto:debian-publicity@lists.debian.org">debian-publicity@lists.debian.org</a>.</gettext></p>
+</define-tag>
+

© 2014-2024 Faster IT GmbH | imprint | privacy policy