aboutsummaryrefslogtreecommitdiffstats
path: root/english/template/debian/past_event.wml
diff options
context:
space:
mode:
authorDarren Benham <gecko>1998-11-06 21:47:51 +0000
committerDarren Benham <gecko>1998-11-06 21:47:51 +0000
commitdfbac230bb070e75218b5b4399935826527260da (patch)
tree25be3fa0bb3ef6a05a3bd895bab3cb4bcca92824 /english/template/debian/past_event.wml
parentb480a0d2f6ef50056931f0d5bedb5323b2e3110d (diff)
More events stuff. Left to do:
* fix the dependencies * tweak the look for Nils * add them to the menubar CVS version numbers english/events/Makefile: 1.5 -> 1.6 english/events/index.wml: 1.4 -> 1.5 english/events/1998/Makefile: 1.2 -> 1.3 english/events/1999/0301-linworldexpo.wml: INITIAL -> 1.1 english/events/1999/0313-thebazaar.wml: INITIAL -> 1.1 english/events/1999/0315-dma.wml: INITIAL -> 1.1 english/events/1999/0518-linux-expo.wml: INITIAL -> 1.1 english/events/1999/Makefile: INITIAL -> 1.1 english/events/1999/index.wml: INITIAL -> 1.1 english/template/debian/event.wml: 1.6 -> 1.7 english/template/debian/event_index.wml: INITIAL -> 1.1 english/template/debian/past_event.wml: INITIAL -> 1.1 english/template/debian/recent_list.wml: 1.6 -> 1.7
Diffstat (limited to 'english/template/debian/past_event.wml')
-rw-r--r--english/template/debian/past_event.wml120
1 files changed, 120 insertions, 0 deletions
diff --git a/english/template/debian/past_event.wml b/english/template/debian/past_event.wml
new file mode 100644
index 00000000000..3823944641f
--- /dev/null
+++ b/english/template/debian/past_event.wml
@@ -0,0 +1,120 @@
+#use wml::debian::basic title="Debian GNU/Linux &mdash; Upcoming Attractions"
+#use wml::debian::languages
+
+<perl>
+#############################################################################
+# grabs the date and title of the last $number news items from directory $path.
+# If $number is zero then all the news items are shown.
+sub get_recent_list
+{
+ my ( $path, $number, $current_dir, $match ) = @_;
+
+ opendir(DIR, "$current_dir/$path");
+ @files = grep { /^$match.wml$/ && -f "$current_dir/$path/$_" } readdir(DIR);
+ @files = sort {$b cmp $a} @files;
+ closedir DIR;
+
+ $str = '<TR><TD>(none)</TD></TR>';
+
+ $count = 0;
+ foreach (@files)
+ {
+ $count++;
+ open(FILE, "<$path/$_") || open(FILE, "<$current_dir/$path/$_");
+ if ( /($match).wml/ )
+ {
+ $base = $1;
+ }
+ $title = ''; $date = ''; $contact = ''; $email = ''; $desc = '';
+ foreach $line (<FILE>)
+ {
+ if ($line =~ /^<define-tag pagetitle>(.*)<\/define-tag>$/)
+ {
+ $title = $1;
+ }
+ elsif ($line =~ /^<define-tag date>(.*)<\/define-tag>$/)
+ {
+ $date = $1;
+ }
+ elsif ($line =~ /^<define-tag contact>(.*)<\/define-tag>$/)
+ {
+ $contact = $1;
+ }
+ elsif ($line =~ /^<define-tag email>(.*)<\/define-tag>$/)
+ {
+ $email = $1;
+ }
+ elsif ($line =~ /^<define-tag desc>(.*)<\/define-tag>$/)
+ {
+ $desc = $1;
+ }
+ if ($title && $date)
+ {
+ $str = "<tt>[$date]</tt> <strong><a href=\"$path/$base\">$title</a></strong><br>\n";
+ last;
+ }
+ elsif ($title && $contact && $email && $desc)
+ {
+ $str = "<TR><TD><A HREF=\"$path/$base\">$title</A></TD><TD><A HREF=\"mailto:$email\">$contact</A></TD><TD>$desc</TD></TR>\n";
+ last;
+ }
+ elsif ($title && $contact && $desc)
+ {
+ $str = "<TR><TD><A HREF=\"$path/$base\">$title</A></TD><TD>$contact</TD><TD>$desc</TD></TR>\n";
+ }
+ }
+ close FILE;
+ if ($count eq $number) { last; }
+ }
+close DIR;
+return $str;
+}
+
+#############################################################################
+# grabs the date and title of the last $number news items from directory $path.
+# If $number is zero then all the news items are shown.
+sub make_link
+{
+ my ( $url, $text, $temp ) = @_;
+
+ if ( $temp eq 'yes' )
+ {
+ $str = "$text - $url (link may nolonger be valid)";
+ }
+ else
+ {
+ $str = "<A HREF=\"$url\">$text</A>";
+ }
+ return $str
+</perl>
+
+<HR>
+<H2><pagetitle></H2>
+ <STRONG>When:</STRONG> <when><BR>
+ <STRONG>Where:</STRONG> <where><BR>
+ <STRONG>More Info:</STRONG><A HREF="<infolink>">Web Page</A><BR>
+
+<HR>
+<intro>
+
+<HR>
+<H2>Debian Involvement</H2>
+<involve>
+
+<TABLE>
+ <TR><TH>Project</TH><TH>Coordinator</TH><TH>Description</TH></TR>
+ <:= get_recent_list ( '<abbr>', '0', '$(ENGLISHDIR)/events/<year>', 'project-\w+' ) :>
+</TABLE>
+
+<HR>
+<H2>Latest News</H2>
+<:= get_recent_list ( '<abbr>', '0', '$(ENGLISHDIR)/events/<year>', 'news-\d+\w*' ) :>
+
+<HR>
+<H2>Related Links</H2>
+<<mainbody>>
+
+<:= languages() :>
+#use wml::debian::footer
+
+..mainbody>>

© 2014-2024 Faster IT GmbH | imprint | privacy policy