aboutsummaryrefslogtreecommitdiffstats
path: root/english/security
diff options
context:
space:
mode:
authorThomas Lange <lange@debian.org>2023-11-25 21:45:54 +0100
committerThomas Lange <lange@debian.org>2023-12-02 16:47:04 +0100
commit69618a77c141053dd70884cfb68ea62bd8e69a60 (patch)
tree92852ea34970347e2bd166ab57c91aad4f6fc66e /english/security
parent7cf91065009e7713c326bab7d56a92e384e8ea18 (diff)
adjust Makefile to new generate.py
Diffstat (limited to 'english/security')
-rw-r--r--english/security/oval/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/english/security/oval/Makefile b/english/security/oval/Makefile
index fb3f246ec1e..8cb2947c216 100644
--- a/english/security/oval/Makefile
+++ b/english/security/oval/Makefile
@@ -17,6 +17,10 @@ XMLDESTFILES=$(patsubst %,$(HTMLDIR)/%,$(XMLFILES))
all:: check_empty_files $(XMLFILES)
install:: $(XMLDESTFILES)
+
+../data/dsa.data:
+ cd ../data && make dsa.data
+
# JSON file to download with security tracker information
# This is a phony target, it will download it only if the file does not
# exist or if it is less than 1 hour old.
@@ -33,9 +37,9 @@ DebianSecTracker.json:
fi \
fi
-oval-definitions-%.xml: force DebianSecTracker.json
+oval-definitions-%.xml: DebianSecTracker.json ../data/dsa.data
@[ -e $(PYTHON) ] || { echo "ERROR: Required python binary $(PYTHON) is not available, aborting generation" >&2; exit 1; }
- $(IGNORE)$(PYTHON) generate.py -q -d .. -j DebianSecTracker.json -r $(patsubst oval-definitions-%.xml,%,$@) >$@
+ $(IGNORE)$(PYTHON) generate.py -q -d ../data/dsa.data -j DebianSecTracker.json -r $(patsubst oval-definitions-%.xml,%,$@) >$@
# Warn if empty files are generated
# Note: They cannot be removed or the install target will fail later
@[ -s $@ ] || echo "WARNING: OVAL Definition $@ is empty, please review script and/or DSAs"

© 2014-2024 Faster IT GmbH | imprint | privacy policy