aboutsummaryrefslogtreecommitdiffstats
path: root/english/security/Makefile
diff options
context:
space:
mode:
authorCyril Brulebois <kibi@debian.org>2019-03-11 00:36:30 +0000
committerCyril Brulebois <kibi@debian.org>2019-03-11 01:33:54 +0000
commit35e5a08057ab8953dcfaceab9f623c52be7a44e4 (patch)
treefe1626fe132cc5f38dc6c94269f2008fbca0381e /english/security/Makefile
parente0496a1974f81c11d576b507c2c2a1d39538d44e (diff)
Reduce entropy by sorting the output of all $(wildcard …) calls
Introducing a function (i.e. sorted_wildcard) seemed to make sense at first but it would need to be defined in all Makefiles, before getting used. That's why a “replace all occurrences” approach was preferred in the end. Many occurrences aren't going to make a difference anyway, because they are about documenting target dependencies. But replacing everything means it's easier to check later on, in case entropy comes back. This file needs a slightly different diff because the Makefile snippet is embedded in a Perl script: english/security/parse-advisory.pl
Diffstat (limited to 'english/security/Makefile')
-rw-r--r--english/security/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/english/security/Makefile b/english/security/Makefile
index 579ed1f90b8..cf7dfa92d11 100644
--- a/english/security/Makefile
+++ b/english/security/Makefile
@@ -3,7 +3,7 @@
WMLBASE=..
CUR_DIR=security
-SUBS=undated $(wildcard [12][0-9][0-9][0-9]) audit oval key-rollover
+SUBS=undated $(sort $(wildcard [12][0-9][0-9][0-9])) audit oval key-rollover
# TODO: Check that 'oval' works now that RT #160 (rt.debian.org) has been closed
GETTEXTFILES += security.mo
@@ -27,9 +27,9 @@ DESTDSALONGRDF := $(patsubst %.rdf,$(HTMLDIR)/%.rdf,$(DSALONGRDF))
endif
-$(INDEXPAGE): index.wml $(wildcard $(CUR_YEAR)/dsa-*.wml) \
- $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-*.wml) \
- $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-*.data) \
+$(INDEXPAGE): index.wml $(sort $(wildcard $(CUR_YEAR)/dsa-*.wml)) \
+ $(sort $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-*.wml)) \
+ $(sort $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-*.data)) \
$(TEMPLDIR)/release_info.wml \
$(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list_security.wml $(GETTEXTDEP)
@@ -50,7 +50,7 @@ faq.$(LANGUAGE).html: faq.wml \
$(ENGLISHSRCDIR)/security/faq.wml \
$(ENGLISHSRCDIR)/security/faq.inc $(GETTEXTDEP)
-$(ENGLISHSRCDIR)/security/ref-table.inc: $(ENGLISHSRCDIR)/security/make-ref-table.pl $(wildcard $(ENGLISHSRCDIR)/security/*/*.data)
+$(ENGLISHSRCDIR)/security/ref-table.inc: $(ENGLISHSRCDIR)/security/make-ref-table.pl $(sort $(wildcard $(ENGLISHSRCDIR)/security/*/*.data))
perl $(ENGLISHSRCDIR)/security/make-ref-table.pl -p -a >$(ENGLISHSRCDIR)/security/ref-table.inc
crossreferences.$(LANGUAGE).html:: $(ENGLISHSRCDIR)/security/ref-table.inc \
@@ -61,9 +61,9 @@ clean::
rm -f ref-table.inc
$(DSARDF): $(ENGLISHDIR)/security/dsa.rdf.in \
- $(wildcard $(CUR_YEAR)/dsa-*.wml) \
- $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.wml) \
- $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.data) \
+ $(sort $(wildcard $(CUR_YEAR)/dsa-*.wml)) \
+ $(sort $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.wml)) \
+ $(sort $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.data)) \
$(TEMPLDIR)/recent_list_security.wml $(GETTEXTDEP)
ifeq "$(LANGUAGE)" "zh"
@echo -n "Processing $(<F): "
@@ -77,9 +77,9 @@ else
endif
$(DSALONGRDF): $(ENGLISHDIR)/security/dsa-long.rdf.in \
- $(wildcard $(CUR_YEAR)/dsa-*.wml) \
- $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.wml) \
- $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.data) \
+ $(sort $(wildcard $(CUR_YEAR)/dsa-*.wml)) \
+ $(sort $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.wml)) \
+ $(sort $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.data)) \
$(TEMPLDIR)/recent_list_security.wml $(GETTEXTDEP)
ifeq "$(LANGUAGE)" "zh"
@echo -n "Processing $(<F): "
@@ -93,9 +93,9 @@ else
endif
$(DSAALLRDF): $(ENGLISHDIR)/security/dsa-all.rdf.in \
- $(wildcard ????/dsa-*.wml) \
- $(wildcard $(ENGLISHDIR)/security/????/dsa-*.wml) \
- $(wildcard $(ENGLISHDIR)/security/????/dsa-*.data) \
+ $(sort $(wildcard ????/dsa-*.wml)) \
+ $(sort $(wildcard $(ENGLISHDIR)/security/????/dsa-*.wml)) \
+ $(sort $(wildcard $(ENGLISHDIR)/security/????/dsa-*.data)) \
$(TEMPLDIR)/recent_list.wml $(GETTEXTDEP)
ifeq "$(LANGUAGE)" "zh"
@echo -n "Processing $(<F): "
@@ -125,7 +125,7 @@ ifeq "$(LANGUAGE)" "en"
map := $(HTMLDIR)/map-dsa.txt
-$(map): $(wildcard $(CUR_YEAR)/dsa-*.wml)
+$(map): $(sort $(wildcard $(CUR_YEAR)/dsa-*.wml))
for i in 2*/dsa-*.wml; do echo $$i $$i | sed -r 's/^.+\/(.+) /\1 /' | sed 's/\.wml//g' | sed 's/^dsa-//' ;done > $(HTMLDIR)/map-dsa.txt
install:: $(map)

© 2014-2024 Faster IT GmbH | imprint | privacy policy