aboutsummaryrefslogtreecommitdiffstats
path: root/english/releases/Makefile
diff options
context:
space:
mode:
authorMartin Schulze <joey>2002-07-24 19:06:34 +0000
committerMartin Schulze <joey>2002-07-24 19:06:34 +0000
commit26f3370ad68ac3562f0070789e3629edd767e360 (patch)
treecf7a5ee56f1e623a5bfd5c755c101b0f9835768d /english/releases/Makefile
parent77ba161b813c26d71c08368c20d95e7934f9068b (diff)
Added support for the ``sid'' distribution. The text needs some
polishing, I'm pretty sure, though... CVS version numbers english/releases/Makefile: 1.16 -> 1.17
Diffstat (limited to 'english/releases/Makefile')
-rw-r--r--english/releases/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/english/releases/Makefile b/english/releases/Makefile
index c70a63d8157..cb04e3dc110 100644
--- a/english/releases/Makefile
+++ b/english/releases/Makefile
@@ -4,7 +4,7 @@
WMLBASE=..
CUR_DIR=releases
-SUBS=hamm slink potato woody sarge
+SUBS=hamm slink potato woody sarge sid
include $(WMLBASE)/Make.lang
@@ -16,6 +16,7 @@ ifeq "$(LANGUAGE)" "en"
# this stuff creates symlinks for releases
tes := $(shell grep current_testing_name info | cut -d\< -f2 | cut -d\> -f2)
rel := $(shell grep current_release_name info | cut -d\< -f2 | cut -d\> -f2)
+uns := sid
install::
@if [ -d $(HTMLDIR)/hamm -a ! -L $(HTMLDIR)/2.0 ]; then ln -sv hamm $(HTMLDIR)/2.0; fi
@@ -25,6 +26,8 @@ install::
@[ -d "$(tes)" -a -d "$(rel)" ] || { echo "No $(tes) or $(rel) directory in releases."; exit 1; }
@if [ "`readlink $(HTMLDIR)/stable`" != "$(rel)" ]; then rm -f $(HTMLDIR)/stable; fi
@if [ "`readlink $(HTMLDIR)/testing`" != "$(tes)" ]; then rm -f $(HTMLDIR)/testing; fi
+ @if [ "`readlink $(HTMLDIR)/unstable`" != "$(uns)" ]; then rm -f $(HTMLDIR)/unstable; fi
@test -L $(HTMLDIR)/stable || ln -sv $(rel) $(HTMLDIR)/stable
@test -L $(HTMLDIR)/testing || ln -sv $(tes) $(HTMLDIR)/testing
+ @test -L $(HTMLDIR)/unstable || ln -sv $(uns) $(HTMLDIR)/unstable
endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy