aboutsummaryrefslogtreecommitdiffstats
path: root/english/blends
diff options
context:
space:
mode:
authorSteve McIntyre <steve@einval.com>2018-06-06 02:14:55 +0100
committerSteve McIntyre <steve@einval.com>2018-06-06 02:20:41 +0100
commit533db96be6c6b97b4bf26203b429f24b2ad56cb4 (patch)
treeb826f626f219ceeedbfadf2c8f14f6811aa89448 /english/blends
parentf035d5bf50874ad2e3c2b25aefcac111b4c5cbb0 (diff)
Major Makefile overhauls
Add rules to generate the git revs cache in Makefile.common, referenced as $(VCSREVCACHE) Add an extra order-only prerequisite on $(VCSREVCACHE) for ~all rules converting .wml to .html, so that we'll make sure we have a cache built up-front before we start building anything. More factorisation of various year-based Makefiles to use a common Make.year set of rules.
Diffstat (limited to 'english/blends')
-rw-r--r--english/blends/hamradio/News/2014/Makefile8
-rw-r--r--english/blends/hamradio/News/2015/Makefile8
2 files changed, 12 insertions, 4 deletions
diff --git a/english/blends/hamradio/News/2014/Makefile b/english/blends/hamradio/News/2014/Makefile
index b6d25542f21..8085084817f 100644
--- a/english/blends/hamradio/News/2014/Makefile
+++ b/english/blends/hamradio/News/2014/Makefile
@@ -9,9 +9,13 @@ NOGENERICDEP := true
include $(WMLBASE)/Make.lang
+# The "| $(VCSREVCACHE)" here is an order-only prerequisite - always
+# check that the prerequisite exists and is up to date, but don't
+# rebuild everything whenever it's updated - see
+# https://www.gnu.org/software/make/manual/html_node/Prerequisite-Types.html
index.$(LANGUAGE).html: index.wml $(wildcard 2014*.wml) \
$(wildcard 2014*.title)\
- $(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list.wml
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list.wml | $(VCSREVCACHE)
$(WML) index.wml
-%.$(LANGUAGE).html: %.wml $(TEMPLDIR)/news.wml
+%.$(LANGUAGE).html: %.wml $(TEMPLDIR)/news.wml | $(VCSREVCACHE)
$(WML) $(<F)
diff --git a/english/blends/hamradio/News/2015/Makefile b/english/blends/hamradio/News/2015/Makefile
index e8708e846e1..f9cd9fa7e28 100644
--- a/english/blends/hamradio/News/2015/Makefile
+++ b/english/blends/hamradio/News/2015/Makefile
@@ -9,9 +9,13 @@ NOGENERICDEP := true
include $(WMLBASE)/Make.lang
+# The "| $(VCSREVCACHE)" here is an order-only prerequisite - always
+# check that the prerequisite exists and is up to date, but don't
+# rebuild everything whenever it's updated - see
+# https://www.gnu.org/software/make/manual/html_node/Prerequisite-Types.html
index.$(LANGUAGE).html: index.wml $(wildcard 2014*.wml) \
$(wildcard 2014*.title)\
- $(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list.wml
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list.wml | $(VCSREVCACHE)
$(WML) index.wml
-%.$(LANGUAGE).html: %.wml $(TEMPLDIR)/news.wml
+%.$(LANGUAGE).html: %.wml $(TEMPLDIR)/news.wml | $(VCSREVCACHE)
$(WML) $(<F)

© 2014-2024 Faster IT GmbH | imprint | privacy policy