aboutsummaryrefslogtreecommitdiffstats
path: root/english/blends
diff options
context:
space:
mode:
authorIain R. Learmonth <irl>2016-01-23 17:18:15 +0000
committerIain R. Learmonth <irl>2016-01-23 17:18:15 +0000
commit4050294e0c5c7da53e648764cf58f63a5f9a31df (patch)
tree73f3540d6d011de3a233209f129517fa5f905177 /english/blends
parent5d18d6e1732148e69902e9cb5fb273ed2af8ccfe (diff)
Modified the blends homepage to seperate data from presentation
This commit seperates the blend data from the presentation on the blends home page. Data is now stored in two files, released.data and unreleased.data that correspond to released and unreleased blends. The file blend.defs defines a few tags that are used in these .data files to allow for easier editing. gettext is used for blend descriptions and for tags within the .defs file. CVS version numbers english/blends/Makefile: 1.2 -> 1.3 english/blends/blend.defs: INITIAL -> 1.1 english/blends/index.wml: 1.18 -> 1.19 english/blends/released.data: INITIAL -> 1.1 english/blends/unreleased.data: INITIAL -> 1.1 english/po/Makefile: 1.100 -> 1.101 english/po/blends.pot: INITIAL -> 1.1 english/po/templates.pot: 1.76 -> 1.77
Diffstat (limited to 'english/blends')
-rw-r--r--english/blends/Makefile6
-rw-r--r--english/blends/blend.defs23
-rw-r--r--english/blends/index.wml116
-rw-r--r--english/blends/released.data93
-rw-r--r--english/blends/unreleased.data86
5 files changed, 244 insertions, 80 deletions
diff --git a/english/blends/Makefile b/english/blends/Makefile
index 137c50876fc..fb8d3a1382a 100644
--- a/english/blends/Makefile
+++ b/english/blends/Makefile
@@ -5,6 +5,10 @@ WMLBASE=..
CUR_DIR=blends
SUBS=Pics hamradio gis
+GETTEXTFILES += blends.mo
+
include $(WMLBASE)/Make.lang
-index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/template.wml
+index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/template.wml \
+ $(ENGLISHDIR)/blends/blend.defs $(ENGLISHDIR)/blends/released.data \
+ $(ENGLISHDIR)/blends/unreleased.data $(GETTEXTDEP)
diff --git a/english/blends/blend.defs b/english/blends/blend.defs
new file mode 100644
index 00000000000..5f741fee146
--- /dev/null
+++ b/english/blends/blend.defs
@@ -0,0 +1,23 @@
+#use wml::debian::common_tags
+
+<bind-gettext-domain domain="blends" />
+
+<define-tag blend whitespace=delete>
+ <td><a href="%1">%0</a></td>
+</define-tag>
+<define-tag description whitespace=delete endtag=required>
+ <td>%body</td>
+</define-tag>
+<define-tag links whitespace=delete endtag=required>
+ <td>%body</td>
+</define-tag>
+<define-tag metapackages whitespace=delete>
+ <a href="%0"><gettext domain="blends">Metapackages</gettext></a>
+</define-tag>
+<define-tag downloads whitespace=delete>
+ <a href="%0"><gettext domain="blends">Downloads</gettext></a>
+</define-tag>
+<define-tag derivatives whitespace=delete>
+ <a href="%0"><gettext domain="blends">Derivatives</gettext></a>
+</define-tag>
+
diff --git a/english/blends/index.wml b/english/blends/index.wml
index 08b6b7fde85..b604d689e08 100644
--- a/english/blends/index.wml
+++ b/english/blends/index.wml
@@ -23,90 +23,48 @@ href="http://blends.debian.org/blends/">Pure Blends Manual</a>.</p>
<li><a href="#development">Development</a></li>
</ul>
-<div id="main">
- <div id="released" class="cardleft">
- <h2>Released Blends</h2>
- <div>
- <p>These blends have been released with Debian <a
-href="https://www.debian.org/releases/jessie/">jessie</a>. Those with official
-installation media available are marked with a <img src="Pics/cd.png"
-alt="[CD]" height="15" width="15">. Those with derivative projects are marked
-with a <img src="Pics/deriv.png" alt="[DERIV]" height="15" width="15">.</p>
- <dl>
- <dt><a href="https://wiki.debian.org/Debichem">DebiChem (Chemistry)</a></dt>
- <dd>The goal of DebiChem is to make Debian a good platform for chemists in
- their day-to-day work.</dd>
- <dt><a href="https://wiki.debian.org/Games">Debian Games</a></dt>
- <dd>The goal of Debian Games is to provide games in Debian from arcade and
- aventure to simulation and strategy.</dd>
- <dt><a href="gis/">Debian GIS (Geographical Information Systems) <img src="Pics/cd.png"
- alt="[CD]" height="15" width="15"><img src="Pics/deriv.png" alt="[DERIV]"
- height="15" width="15"></a></dt>
- <dd>The goal of Debian GIS is to develop Debian into the best distribution
- for Geographical Information System applications and users.</dd>
- <dt><a href="https://wiki.debian.org/DebianJr">Debian Junior</a></dt>
- <dd>The goal of Debian Junior is to make Debian an OS that children will
- enjoy using.</dd>
- <dt><a href="../devel/med/">Debian Med (Medical and Life Sciences)</a></dt>
- <dd>The goal of Debian Med is a complete free and open system for all tasks
- in medical care and research. To achieve this goal Debian Med
- integrates related free and open source software for medical imaging,
- bioinformatics, clinic IT infrastructure, and others within the Debian
- OS.</dd>
- <dt><a href="https://wiki.debian.org/DebianMultimedia">Debian Multimedia</a></dt>
- <dd>The goal of Debian Multimedia is to make Debian a good platform for
- audio and multimedia work.</dd>
- <dt><a href="https://wiki.debian.org/DebianScience/Blend">Debian Science</a></dt>
- <dd>The goal of Debian Science is to provide a better experience when using
- Debian to researchers and scientists.</dd>
- </dl>
- </div>
- </div>
- <div id="unreleased" class="cardright">
+<div class="card" id="released">
+<h2>Released Blends</h2>
+<div>
+<p>"Released" may have different meanings for different blends. At a minimum,
+it means that the blend has metapackages that were released in a stable release
+of Debian, although blends may also provide installation media or form the
+basis of a derivative distribution. See the individual blend pages for more
+information on that particular blend.</p>
+
+<table class="tabular" summary="">
+<tbody>
+ <tr>
+ <th>Blend</th>
+ <th>Description</th>
+ <th>Quick Links</th>
+ </tr>
+#include "released.data"
+</tbody>
+</table>
+</div>
+</div>
+
+<div class="card" id="unreleased">
<h2>Unreleased Blends</h2>
<div>
<p>These blends are works-in-progress and have not yet made a stable release
although they may be available in the <a
-href="https://www.debian.org/releases/testing/">testing</a> distribution. Those
-with unofficial installation media available are marked with a <img
-src="Pics/cd.png" alt="[CD]" height="15" width="15">. Those with derivative
-projects are marked with a <img src="Pics/deriv.png" alt="[DERIV]" height="15"
-width="15">.</p>
- <dl>
- <dt><a href="http://blends.debian.org/accessibility">Debian Accessibility</a></dt>
- <dd>The goal of Debian Accessibility is to develop Debian into an operating
- system that is particularly well suited for the requirements of people
- with disabilities.</dd>
- <dt><a href="https://wiki.debian.org/Design">Debian Design</a></dt>
- <dd>The goal of Debian Design is to provide applications for designers.
- This includes graphic design, web design and multimedia design.</dd>
- <dt><a href="https://wiki.debian.org/DebianEdu">Debian Edu (Education)</a></dt>
- <dd>The goal of Debian Edu is to provide a Debian OS system suitable for
- educational use and in schools.</dd>
- <dt><a href="http://blends.debian.org/ezgo">Debian EzGo (Asian Localisation)</a></dt>
- <dd>The goal of Debian EzGo is to provide culture-based open and free
- technology with native language support and appropriate user friendly,
- lightweight and fast desktop environment for low powerful/cost
- hardwares to empower human capacity building and technology development
- in many areas and regions, like Africa, Afghanistan, Indonesia, Vietnam
- using Debian.</dd>
- <dt><a href="https://wiki.debian.org/FreedomBox">FreedomBox</a></dt>
- <dd>The goal of FreedomBox is to develop, design and promote personal
- servers running free software for private, personal communications.
- Applications include blogs, wikis, websites, social networks, email,
- web proxy and a Tor relay on a device that can replace a wireless
- router so that data stays with the users.</dd>
- <dt><a href="./hamradio">Debian Hamradio</a> <img src="Pics/cd.png" alt="[CD]" height="15" width="15"></dt>
- <dd>The goal of Debian Hamradio is to support the needs of radio amateurs
- in Debian by providing logging, data mode and packet mode applications
- and more.</dd>
- <dt><a href="https://wiki.debian.org/DebianParl">DebianParl (for Parliamentarians)</a></dt>
- <dd>The goal of DebianParl is to provide applications to support the needs
- of parliamentarians, politicians and their staffers all around the
- world.</dd>
- </dl>
+href="https://www.debian.org/releases/testing/">testing</a> or <a
+href="https://www.debian.org/releases/unstable">unstable</a> distribution.</p>
+
+<table class="tabular" summary="">
+<tbody>
+ <tr>
+ <th>Blend</th>
+ <th>Description</th>
+ <th>Quick Links</th>
+ </tr>
+#include "unreleased.data"
+</tbody>
+</table>
</div>
- </div><!-- .cardright -->
+ </div>
<div class="card" id="development">
<h2>Development</h2>
<div>
diff --git a/english/blends/released.data b/english/blends/released.data
new file mode 100644
index 00000000000..db0129e1937
--- /dev/null
+++ b/english/blends/released.data
@@ -0,0 +1,93 @@
+#use wml::debian::countries
+#include "$(ENGLISHDIR)/blends/blend.defs"
+
+# Note to translators: there is nothing to translate in this file, see the
+# blends POT file instead.
+
+# When adding a new blend to this file, ensure that gettext is used for
+# the description.
+#
+# The blend, description and links tags are all mandatory although the body of
+# the links tag may be empty if there are no relevant links.
+
+<tr>
+<blend "DebiChem" "https://wiki.debian.org/Debichem">
+<description><gettext domain="blends">
+The goal of DebiChem is to make Debian a good platform
+for chemists in their day-to-day work.</gettext>
+</gettext></description>
+<links>
+<metapackages "https://blends.debian.org/debichem/tasks">
+</links>
+</tr>
+
+<tr>
+<blend "Debian Games" "https://wiki.debian.org/Games">
+<description><gettext domain="blends">
+The goal of Debian Games is to provide games in Debian from
+arcade and aventure to simulation and strategy.
+</gettext></description>
+<links>
+<metapackages "https://blends.debian.org/games/tasks">
+</links>
+</tr>
+
+<tr>
+<blend "Debian GIS" "gis/">
+<description><gettext domain="blends">
+The goal of Debian GIS is to develop Debian into the best
+distribution for Geographical Information System applications and users.
+</gettext></description>
+<links>
+<metapackages "gis/get/metapackages">
+<downloads "gis/get/live">
+<derivatives "gis/deriv">
+</links>
+</tr>
+
+<tr>
+<blend "Debian Junior">
+<description><gettext domain="blends">
+The goal of Debian Junior is to make Debian an OS that children
+will enjoy using.
+</gettext></description>
+<links>
+<metapackages "https://blends.debian.org/junior/tasks">
+</links>
+</tr>
+
+<tr>
+<blend "Debian Med">
+<description><gettext domain="blends">
+The goal of Debian Med is a complete free and open system for all
+tasks in medical care and research. To achieve this goal Debian Med integrates
+related free and open source software for medical imaging, bioinformatics,
+clinic IT infrastructure, and others within the Debian OS.
+</gettext></description>
+<links>
+<metapackages "https://blends.debian.org/med/tasks">
+</links>
+</tr>
+
+<tr>
+<blend "Debian Multimedia">
+<description><gettext domain="blends">
+The goal of Debian Multimedia is to make Debian a good platform
+for audio and multimedia work.
+</gettext></description>
+<links>
+<metapackages "https://blends.debian.org/multimedia/tasks">
+</links>
+</tr>
+
+<tr>
+<blend "Debian Science">
+<description><gettext domain="blends">
+The goal of Debian Science is to provide a better experience when
+using Debian to researchers and scientists.
+</gettext></description>
+<links>
+<metapackages "https://blends.debian.org/science/tasks">
+</links>
+</tr>
+
diff --git a/english/blends/unreleased.data b/english/blends/unreleased.data
new file mode 100644
index 00000000000..5ad257cc5bd
--- /dev/null
+++ b/english/blends/unreleased.data
@@ -0,0 +1,86 @@
+#use wml::debian::countries
+#include "$(ENGLISHDIR)/blends/blend.defs"
+
+# Note to translators: there is nothing to translate in this file, see the
+# blends POT file instead.
+
+# When adding a new blend to this file, ensure that gettext is used for
+# the description.
+#
+# The blend, description and links tags are all mandatory although the body of
+# the links tag may be empty if there are no relevant links.
+
+<tr>
+<blend "Debian Accessibility" "http://blends.debian.org/accessibility">
+<description><gettext domain="blends">
+The goal of Debian Accessibility is to develop Debian into an
+operating system that is particularly well suited for the requirements of
+people with disabilities.
+</gettext></description>
+<links>
+<metapackages "http://blends.debian.org/accessibility/tasks">
+</links>
+</tr>
+
+<tr>
+<blend "Debian Design" "https://wiki.debian.org/Design">
+<description><gettext domain="blends">
+The goal of Debian Design is to provide applications for
+designers. This includes graphic design, web design and multimedia design.
+</gettext></description>
+<links>
+</links>
+</tr>
+
+<tr>
+<blend "Debian EzGo" "http://blends.debian.org/ezgo/tasks">
+<description><gettext domain="blends">
+The goal of Debian EzGo is to provide culture-based open and free
+technology with native language support and appropriate user friendly,
+lightweight and fast desktop environment for low powerful/cost
+hardwares to empower human capacity building and technology development in
+many areas and regions, like Africa, Afghanistan, Indonesia, Vietnam using
+Debian.
+</gettext></description>
+<links>
+<metapackages "http://blends.debian.org/ezgo/tasks">
+</links>
+</tr>
+
+<tr>
+<blend "FreedomBox" "https://wiki.debian.org/FreedomBox">
+<description><gettext domain="blends">
+The goal of FreedomBox is to develop, design and promote personal
+servers running free software for private, personal communications.
+Applications include blogs, wikis, websites, social networks, email, web proxy
+and a Tor relay on a device that can replace a wireless router so that data
+stays with the users.
+</gettext></description>
+<links>
+<downloads "https://wiki.debian.org/FreedomBox/Download">
+</links>
+</tr>
+
+<tr>
+<blend "Debian Hamradio" "hamradio/">
+<description><gettext domain="blends">
+The goal of Debian Hamradio is to support the needs of radio
+amateurs in Debian by providing logging, data mode and packet mode
+applications and more.
+</gettext></description>
+<links>
+<metapackages "hamradio/get/metapackages">
+<downloads "hamradio/get/live">
+</links>
+</tr>
+
+<tr>
+<blend "DebianParl" "https://wiki.debian.org/DebianParl">
+<description><gettext domain="blends">
+The goal of DebianParl is to provide applications to support the
+needs of parliamentarians, politicians and their staffers all around the
+world.
+</gettext></description>
+<links>
+</links>
+</tr>

© 2014-2024 Faster IT GmbH | imprint | privacy policy