aboutsummaryrefslogtreecommitdiffstats
path: root/english/blends
diff options
context:
space:
mode:
authorCyril Brulebois <kibi@debian.org>2019-03-11 00:36:30 +0000
committerCyril Brulebois <kibi@debian.org>2019-03-11 01:33:54 +0000
commit35e5a08057ab8953dcfaceab9f623c52be7a44e4 (patch)
treefe1626fe132cc5f38dc6c94269f2008fbca0381e /english/blends
parente0496a1974f81c11d576b507c2c2a1d39538d44e (diff)
Reduce entropy by sorting the output of all $(wildcard …) calls
Introducing a function (i.e. sorted_wildcard) seemed to make sense at first but it would need to be defined in all Makefiles, before getting used. That's why a “replace all occurrences” approach was preferred in the end. Many occurrences aren't going to make a difference anyway, because they are about documenting target dependencies. But replacing everything means it's easier to check later on, in case entropy comes back. This file needs a slightly different diff because the Makefile snippet is embedded in a Perl script: english/security/parse-advisory.pl
Diffstat (limited to 'english/blends')
-rw-r--r--english/blends/hamradio/News/2014/Makefile4
-rw-r--r--english/blends/hamradio/News/2015/Makefile4
-rw-r--r--english/blends/hamradio/News/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/english/blends/hamradio/News/2014/Makefile b/english/blends/hamradio/News/2014/Makefile
index 8085084817f..80eef90336e 100644
--- a/english/blends/hamradio/News/2014/Makefile
+++ b/english/blends/hamradio/News/2014/Makefile
@@ -13,8 +13,8 @@ include $(WMLBASE)/Make.lang
# check that the prerequisite exists and is up to date, but don't
# rebuild everything whenever it's updated - see
# https://www.gnu.org/software/make/manual/html_node/Prerequisite-Types.html
-index.$(LANGUAGE).html: index.wml $(wildcard 2014*.wml) \
- $(wildcard 2014*.title)\
+index.$(LANGUAGE).html: index.wml $(sort $(wildcard 2014*.wml)) \
+ $(sort $(wildcard 2014*.title))\
$(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list.wml | $(VCSREVCACHE)
$(WML) index.wml
%.$(LANGUAGE).html: %.wml $(TEMPLDIR)/news.wml | $(VCSREVCACHE)
diff --git a/english/blends/hamradio/News/2015/Makefile b/english/blends/hamradio/News/2015/Makefile
index f9cd9fa7e28..d6785f32e99 100644
--- a/english/blends/hamradio/News/2015/Makefile
+++ b/english/blends/hamradio/News/2015/Makefile
@@ -13,8 +13,8 @@ include $(WMLBASE)/Make.lang
# check that the prerequisite exists and is up to date, but don't
# rebuild everything whenever it's updated - see
# https://www.gnu.org/software/make/manual/html_node/Prerequisite-Types.html
-index.$(LANGUAGE).html: index.wml $(wildcard 2014*.wml) \
- $(wildcard 2014*.title)\
+index.$(LANGUAGE).html: index.wml $(sort $(wildcard 2014*.wml)) \
+ $(sort $(wildcard 2014*.title))\
$(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list.wml | $(VCSREVCACHE)
$(WML) index.wml
%.$(LANGUAGE).html: %.wml $(TEMPLDIR)/news.wml | $(VCSREVCACHE)
diff --git a/english/blends/hamradio/News/Makefile b/english/blends/hamradio/News/Makefile
index 8be05993a4b..184b58b3ea2 100644
--- a/english/blends/hamradio/News/Makefile
+++ b/english/blends/hamradio/News/Makefile
@@ -5,11 +5,11 @@ WMLBASE=../../..
CUR_DIR=blends/hamradio/News
# list any subdirectories in the following variable. If a listed directory
# exists, it must contain a Makefile, or make gives an error
-YEARS:=$(wildcard [12][0-9][0-9][0-9])
+YEARS:=$(sort $(wildcard [12][0-9][0-9][0-9]))
SUBS=$(YEARS)
include $(WMLBASE)/Make.lang
index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/template.wml \
$(TEMPLDIR)/recent_list.wml \
- $(wildcard $(ENGLISHSRCDIR)/$(CUR_DIR)/[0-9]*/*.wml)
+ $(sort $(wildcard $(ENGLISHSRCDIR)/$(CUR_DIR)/[0-9]*/*.wml))

© 2014-2024 Faster IT GmbH | imprint | privacy policy