aboutsummaryrefslogtreecommitdiffstats
path: root/english/CD/Makefile
diff options
context:
space:
mode:
authorSteve McIntyre <steve@einval.com>2018-06-06 02:14:55 +0100
committerSteve McIntyre <steve@einval.com>2018-06-06 02:20:41 +0100
commit533db96be6c6b97b4bf26203b429f24b2ad56cb4 (patch)
treeb826f626f219ceeedbfadf2c8f14f6811aa89448 /english/CD/Makefile
parentf035d5bf50874ad2e3c2b25aefcac111b4c5cbb0 (diff)
Major Makefile overhauls
Add rules to generate the git revs cache in Makefile.common, referenced as $(VCSREVCACHE) Add an extra order-only prerequisite on $(VCSREVCACHE) for ~all rules converting .wml to .html, so that we'll make sure we have a cache built up-front before we start building anything. More factorisation of various year-based Makefiles to use a common Make.year set of rules.
Diffstat (limited to 'english/CD/Makefile')
-rw-r--r--english/CD/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/english/CD/Makefile b/english/CD/Makefile
index 3a9646fc114..125a811ee64 100644
--- a/english/CD/Makefile
+++ b/english/CD/Makefile
@@ -10,7 +10,17 @@ GETTEXTFILES += cdimage.mo
NOGENERICDEP := true
include $(WMLBASE)/Make.lang
-%.$(LANGUAGE).html: %.wml $(WMLRCDEP) $(GETTEXTDEP) $(TEMPLDIR)/cdimage.wml
+ifeq "$(LANGUAGE)" "en"
+ EXTRAWMLDEP := $(WMLRCDEP) $(GETTEXTDEP) $(TEMPLDIR)/cdimage.wml
+else
+ EXTRAWMLDEP := $(WMLRCDEP) $(GETTEXTDEP) $(TEMPLDIR)/cdimage.wml $(TEMPLDIR)/translation-check.wml
+endif
+
+# The "| $(VCSREVCACHE)" here is an order-only prerequisite - always
+# check that the prerequisite exists and is up to date, but don't
+# rebuild everything whenever it's updated - see
+# https://www.gnu.org/software/make/manual/html_node/Prerequisite-Types.html
+%.$(LANGUAGE).html: %.wml $(EXTRAWMLDEP) | $(VCSREVCACHE)
$(WML) $(<F)
ifneq "$(wildcard releases/index.wml)" ""

© 2014-2024 Faster IT GmbH | imprint | privacy policy