aboutsummaryrefslogtreecommitdiffstats
path: root/danish/reports/Makefile
diff options
context:
space:
mode:
authorKåre Thor Olsen <kaare>2011-07-11 09:31:22 +0000
committerKåre Thor Olsen <kaare>2011-07-11 09:31:22 +0000
commit5d35b3e9e3bd801c8a6fba86afab239de091654d (patch)
tree276705b8b5168ac69604917da7ca1f7d58577e95 /danish/reports/Makefile
parentca88c401ae2becc52b45620fb2204c2fc85ed4b7 (diff)
Initial translation
CVS version numbers danish/News/2011/20110709.wml: INITIAL -> 1.1 danish/reports/Makefile: INITIAL -> 1.1 danish/reports/index.wml: INITIAL -> 1.1
Diffstat (limited to 'danish/reports/Makefile')
-rw-r--r--danish/reports/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/danish/reports/Makefile b/danish/reports/Makefile
new file mode 100644
index 00000000000..78926354513
--- /dev/null
+++ b/danish/reports/Makefile
@@ -0,0 +1,28 @@
+# If this makefile is not generic enough to support a translation,
+# please contact debian-www.
+
+WMLBASE=..
+CUR_DIR=releases
+SUBS=hamm slink potato woody sarge etch lenny squeeze wheezy sid
+
+include $(WMLBASE)/Make.lang
+
+
+index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/template.wml \
+ $(TEMPLDIR)/release_info.wml
+
+ifeq "$(LANGUAGE)" "en"
+# this stuff creates symlinks for releases
+tes := $(shell grep "define-tag current_testing_name" $(TEMPLDIR)/release_info.wml | grep -v ^\# | cut -d\< -f2 | cut -d\> -f2)
+rel := $(shell grep "define-tag current_release_name" $(TEMPLDIR)/release_info.wml | grep -v ^\# | cut -d\< -f2 | cut -d\> -f2)
+old := $(shell grep "define-tag current_oldstable_name" $(TEMPLDIR)/release_info.wml | grep -v ^\# | cut -d\< -f2 | cut -d\> -f2)
+
+install::
+ @[ -d "$(tes)" -a -d "$(rel)" ] || { echo "No $(tes) (testing) or $(rel) (stable) directory in releases."; exit 1; }
+ @if [ "`readlink $(HTMLDIR)/oldstable`" != "$(old)" ]; then rm -f $(HTMLDIR)/oldstable; fi
+ @if [ "`readlink $(HTMLDIR)/stable`" != "$(rel)" ]; then rm -f $(HTMLDIR)/stable; fi
+ @if [ "`readlink $(HTMLDIR)/testing`" != "$(tes)" ]; then rm -f $(HTMLDIR)/testing; fi
+ @test -L $(HTMLDIR)/oldstable || ln -sv $(old) $(HTMLDIR)/oldstable
+ @test -L $(HTMLDIR)/stable || ln -sv $(rel) $(HTMLDIR)/stable
+ @test -L $(HTMLDIR)/testing || ln -sv $(tes) $(HTMLDIR)/testing
+endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy