aboutsummaryrefslogtreecommitdiffstats
path: root/danish/Makefile
diff options
context:
space:
mode:
authorJosip Rodin <joy>2001-05-28 17:36:00 +0000
committerJosip Rodin <joy>2001-05-28 17:36:00 +0000
commit7f2bc984231c010f9f1cba4fc043c80585c11ac7 (patch)
treea547ee54b455f878fac3cbad1f14bd5a8084116a /danish/Makefile
parent8d89ac709b8731fbf050c27b682830b8f63411f1 (diff)
copied from english/ (yeah, it's a mess, it sucks, but it works)
CVS version numbers arabic/Makefile: 1.10 -> 1.11 chinese/Makefile: 1.22 -> 1.23 croatian/Makefile: 1.27 -> 1.28 danish/Makefile: 1.14 -> 1.15 dutch/Makefile: 1.8 -> 1.9 esperanto/Makefile: 1.10 -> 1.11 finnish/Makefile: 1.14 -> 1.15 french/Makefile: 1.26 -> 1.27 german/Makefile: 1.29 -> 1.30 greek/Makefile: 1.5 -> 1.6 hungarian/Makefile: 1.11 -> 1.12 italian/Makefile: 1.34 -> 1.35 japanese/Makefile: 1.30 -> 1.31 korean/Makefile: 1.13 -> 1.14 norwegian/Makefile: 1.11 -> 1.12 polish/Makefile: 1.16 -> 1.17 portuguese/Makefile: 1.14 -> 1.15 romanian/Makefile: 1.14 -> 1.15 russian/Makefile: 1.11 -> 1.12 spanish/Makefile: 1.26 -> 1.27 swedish/Makefile: 1.18 -> 1.19 turkish/Makefile: 1.10 -> 1.11
Diffstat (limited to 'danish/Makefile')
-rw-r--r--danish/Makefile48
1 files changed, 39 insertions, 9 deletions
diff --git a/danish/Makefile b/danish/Makefile
index ab7644c3ab6..1f7c529c0de 100644
--- a/danish/Makefile
+++ b/danish/Makefile
@@ -8,25 +8,55 @@ SUBS=Bugs MailingLists News Pics banners chinese consultants devel distrib \
doc events intro international logos mirror misc partners ports releases \
searchtmpl security vote y2k
+ifneq "$(wildcard om_svenska/Makefile)" ""
+SUBS += om_svenska
+endif
+
include $(WMLBASE)/Make.lang
-ifneq "$(LANGUAGE)" "en"
-sitemap.$(LANGUAGE).html: $(ENGLISHDIR)/sitemap.wml
- $(shell echo $(WML) | sed s/index/sitemap/) \
- $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml \
- $(shell egrep '^-D (CUR_|CHAR)' .wmlrc)
-endif
-
index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/mainpage.wml \
$(wildcard News/$(CUR_YEAR)/[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/News/$(CUR_YEAR)/[0-9]*.wml) \
$(wildcard security/$(CUR_YEAR)/dsa-[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-[0-9]*.wml) \
$(TEMPLDIR)/ctime.wml $(TEMPLDIR)/recent_list.wml $(TEMPLDIR)/languages.wml \
- $(ENGLISHSRCDIR)/releases/info sitemap.$(LANGUAGE).html
+ $(ENGLISHSRCDIR)/releases/info
$(WML) index.wml
+sitemap.$(LANGUAGE).html: $(ENGLISHDIR)/sitemap.wml \
+ $(TEMPLDIR)/links.tags.wml $(TEMPLDIR)/template.wml \
+ $(ENGLISHDIR)/releases/info
+ make -C MailingLists subscribe.$(LANGUAGE).html unsubscribe.$(LANGUAGE).html
+ifeq "$(LANGUAGE)" "zh"
+ $(shell echo $(WML) | sed s/:.zh/:sitemap.zh/g) \
+ $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml \
+ $(shell egrep '^-D (CUR_|CHAR)' .wmlrc)
+ @echo -n " * Converting: [zh_CN.GB2312], "
+ @$(B5TOGB) < sitemap.zh-cn.html.tmp > sitemap.zh-cn.html
+ @rm -f sitemap.zh-cn.html.tmp
+ @$(TOCN) sitemap.zh-cn.html
+ @echo -n "[zh_HK.Big5], "
+ @mv -f sitemap.zh-hk.html.tmp sitemap.zh-hk.html
+ @$(TOHK) sitemap.zh-hk.html
+ @echo "[zh_TW.Big5]."
+ @mv -f sitemap.zh-tw.html.tmp sitemap.zh-tw.html
+ @$(TOTW) sitemap.zh-tw.html
+else
+ifeq "$(LANGUAGE)" "ja"
+ wml -q -D CUR_YEAR=2001 -o UNDEFuJA:sitemap.ja.html.tmp@g+w \
+ --prolog="/usr/bin/kcc -e -" --epilog="./convert sitemap.ja.html" \
+ ../english/sitemap.wml \
+ -D CUR_LANG=Japanese -D CUR_ISO_LANG=ja -D CHARSET=iso-2022-jp
+else
+ $(shell echo $(WML) | sed s/index/sitemap/) \
+ $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml \
+ $(shell egrep '^-D (CUR_|CHAR)' .wmlrc)
+endif
+endif
+
+all:: sitemap.$(LANGUAGE).html
+
install::
test -L $(HTMLDIR)/intl || ln -sf international $(HTMLDIR)/intl
ifneq "$(LANGUAGE)" "en"
- -install -m 664 -p sitemap.$(LANGUAGE).html $(HTMLDIR)
+ -install -m 664 -p sitemap.$(LANGUAGE)*.html $(HTMLDIR)
endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy