aboutsummaryrefslogtreecommitdiffstats
path: root/danish/Makefile
diff options
context:
space:
mode:
authorMartin Schulze <joey>2001-06-04 13:13:19 +0000
committerMartin Schulze <joey>2001-06-04 13:13:19 +0000
commit722220ff6f15138d5ed8a68e2c80735dc6cecb7f (patch)
treec83ba3ad6e0340802ce1b51b17f2a6afba180170 /danish/Makefile
parent06b8db279ad1d44c7f66a210e8380bee61c7fc0e (diff)
Finally tweaked the Makefile again to handle chinese sitemaps
properly. This should be the make[tm] way to go. It's tested now, and it works. Yeah! One day I'll be a Makefile guru. CVS version numbers chinese/Makefile: 1.27 -> 1.28 croatian/Makefile: 1.32 -> 1.33 danish/Makefile: 1.19 -> 1.20 dutch/Makefile: 1.13 -> 1.14 english/Makefile: 1.63 -> 1.64 esperanto/Makefile: 1.15 -> 1.16 finnish/Makefile: 1.19 -> 1.20 french/Makefile: 1.31 -> 1.32 german/Makefile: 1.34 -> 1.35 greek/Makefile: 1.10 -> 1.11 hungarian/Makefile: 1.16 -> 1.17 italian/Makefile: 1.39 -> 1.40 japanese/Makefile: 1.35 -> 1.36 korean/Makefile: 1.18 -> 1.19 norwegian/Makefile: 1.16 -> 1.17 polish/Makefile: 1.21 -> 1.22 portuguese/Makefile: 1.19 -> 1.20 romanian/Makefile: 1.19 -> 1.20 russian/Makefile: 1.16 -> 1.17 spanish/Makefile: 1.31 -> 1.32 swedish/Makefile: 1.23 -> 1.24 turkish/Makefile: 1.15 -> 1.16
Diffstat (limited to 'danish/Makefile')
-rw-r--r--danish/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/danish/Makefile b/danish/Makefile
index 60be0e723df..243597ec95b 100644
--- a/danish/Makefile
+++ b/danish/Makefile
@@ -14,6 +14,14 @@ endif
include $(WMLBASE)/Make.lang
+ifndef SUBLANG
+SITEMAP = sitemap.$(LANGUAGE).html
+HTMLMAP = $(HTMLDIR)/$(SITEMAP)
+else
+SITEMAP = $(sort $(foreach i,$(SUBLANG),\
+ $(patsubst %.wml,%.$(LANGUAGE)-$(i).html,sitemap.wml)))
+HTMLMAP = $(patsubst %.html,$(HTMLDIR)/%.html,$(SITEMAP))
+endif
index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/mainpage.wml \
$(wildcard News/$(CUR_YEAR)/[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/News/$(CUR_YEAR)/[0-9]*.wml) \
@@ -22,7 +30,7 @@ index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/mainpage.wml \
$(ENGLISHSRCDIR)/releases/info
$(WML) index.wml
-sitemap.$(LANGUAGE).html: $(ENGLISHDIR)/sitemap.wml \
+$(SITEMAP): $(ENGLISHDIR)/sitemap.wml \
$(TEMPLDIR)/links.tags.wml $(TEMPLDIR)/template.wml \
$(ENGLISHDIR)/releases/info $(ENGLISHDIR)/MailingLists/mklist.tags
ifeq "$(LANGUAGE)" "zh"
@@ -52,10 +60,7 @@ else
endif
endif
-all:: sitemap.$(LANGUAGE).html
+all:: $(SITEMAP)
-install:: $(HTMLDIR)/sitemap.$(LANGUAGE).html
+install:: $(HTMLMAP)
test -L $(HTMLDIR)/intl || ln -sf international $(HTMLDIR)/intl
-ifneq "$(LANGUAGE)" "en"
- -install -m 664 -p sitemap.$(LANGUAGE)*.html $(HTMLDIR)
-endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy