aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/Make.lang
diff options
context:
space:
mode:
authorAnthony Fok <foka>2011-04-07 22:47:38 +0000
committerAnthony Fok <foka>2011-04-07 22:47:38 +0000
commit159ea344a6ea5aef17c39a0424aae2732bef452b (patch)
treece0e24719078c2b6c92098bce5588507fa19df88 /chinese/Make.lang
parent7e9aae95816928e4346d18c1a8dd39b84011ade0 (diff)
Streamline generation of Chinese variant pages by moving
the set of commands into one chinese/bin/generate-zh-variants.sh . Various Makefile are updated accordingly. Also, due to UTF-8 problems, the in-place "-i" option has been removed from the shebang line in tocn.pl and totw.pl Furthermore, these Chinese specific Perl scripts have been updated to improve translation of certain Chinese pages. CVS version numbers chinese/Make.lang: 1.43 -> 1.44 chinese/bin/fix_big5.pl: 1.10 -> 1.11 chinese/bin/generate-zh-variants.sh: INITIAL -> 1.1 chinese/bin/tocn.pl: 1.42 -> 1.43 chinese/bin/totw.pl: 1.41 -> 1.42 english/Makefile: 1.88 -> 1.89 english/News/Makefile: 1.28 -> 1.29 english/News/weekly/Makefile: 1.52 -> 1.53 english/devel/website/stats/Makefile: 1.3 -> 1.4 english/security/Makefile: 1.65 -> 1.66
Diffstat (limited to 'chinese/Make.lang')
-rw-r--r--chinese/Make.lang29
1 files changed, 7 insertions, 22 deletions
diff --git a/chinese/Make.lang b/chinese/Make.lang
index 1ca86a3433e..9d7b0c288ef 100644
--- a/chinese/Make.lang
+++ b/chinese/Make.lang
@@ -9,6 +9,8 @@ include $(WMLBASE)/../Makefile.common
# If you need to modify that is already defined in ../Makefile.common
# you can put it below
+export LANG=C
+
# Experimental tag by the Debian Chinese Translation Team
SHELL = /bin/bash
BIN = $(WMLBASE)/bin
@@ -16,8 +18,9 @@ BIN = $(WMLBASE)/bin
ICONV = /usr/bin/iconv
B5TOGB = ( $(ICONV) -f UTF-8 -t big5 | $(ICONV) -f big5 -t gb2312 | $(ICONV) -f gb2312 -t UTF-8 )
TOCN = $(BIN)/tocn.pl
-TOHK = $(BIN)/tohk.pl
TOTW = $(BIN)/totw.pl
+TOHK = $(BIN)/tohk.pl
+GENERATE_ZH_VARIANTS = $(BIN)/generate-zh-variants.sh
FIX_BIG5 = $(BIN)/fix_big5.pl
ZHTEMPLATE = $(WMLBASE)/template/debian-zh/template.tmpl
@@ -97,32 +100,14 @@ ifndef NOGENERICDEP
$(COMMONPICS_ZH)
@echo -n "Processing $(<F): "
@$(WML) $(<F)
- @echo -n "[zh_CN], "
- @$(B5TOGB) < $*.zh-cn.html.tmp > $*.zh-cn.html
- @rm -f $*.zh-cn.html.tmp
- @$(TOCN) $*.zh-cn.html
- @echo -n "[zh_HK], "
- @mv -f $*.zh-hk.html.tmp $*.zh-hk.html
- @$(TOHK) $*.zh-hk.html
- @echo "[zh_TW]."
- @mv -f $*.zh-tw.html.tmp $*.zh-tw.html
- @$(TOTW) $*.zh-tw.html
+ @$(GENERATE_ZH_VARIANTS) $* html
else
%.zh-cn.html %.zh-hk.html %.zh-tw.html: %.wml \
$(TOCN) $(TOHK) $(TOTW) $(ZHTEMPLATE) $(GETTEXTDEP) \
$(COMMONPICS_ZH)
- @echo -n "Processing $(@D)/$(<F): "
+ @echo -n "Processing $(<F): "
@cd $(@D) && $(WML) $(notdir $(<))
- @echo -n "[zh_CN], "
- @$(B5TOGB) < $*.zh-cn.html.tmp > $*.zh-cn.html
- @rm -f $*.zh-cn.html.tmp
- @$(TOCN) $*.zh-cn.html
- @echo -n "[zh_HK], "
- @mv -f $*.zh-hk.html.tmp $*.zh-hk.html
- @$(TOHK) $*.zh-hk.html
- @echo "[zh_TW]."
- @mv -f $*.zh-tw.html.tmp $*.zh-tw.html
- @$(TOTW) $*.zh-tw.html
+ @$(GENERATE_ZH_VARIANTS) $* html
endif
# template dependencies

© 2014-2024 Faster IT GmbH | imprint | privacy policy