aboutsummaryrefslogtreecommitdiffstats
path: root/catalan/security
diff options
context:
space:
mode:
authorJordi Mallach <jordi>2002-03-25 19:59:12 +0000
committerJordi Mallach <jordi>2002-03-25 19:59:12 +0000
commit08239866204d67c0f67be49af9546b9c8e47801f (patch)
tree28d03ae4a9b78d9822490a05af50ef9a0bc66947 /catalan/security
parent0beb057b9b8b1ced3cea64b8cdcbc12b3a67da3a (diff)
Forgot Makefile.
CVS version numbers catalan/security/Makefile: INITIAL -> 1.1
Diffstat (limited to 'catalan/security')
-rw-r--r--catalan/security/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/catalan/security/Makefile b/catalan/security/Makefile
new file mode 100644
index 00000000000..ae9e957cc40
--- /dev/null
+++ b/catalan/security/Makefile
@@ -0,0 +1,64 @@
+# This Makefile should need no changes from webwml/english/security/Makefile
+# Please send a message to debian-www if you need to modify anything, so the
+# problem can be fixed.
+
+WMLBASE=..
+CUR_DIR=security
+SUBS=undated $(wildcard [12][0-9][0-9][0-9])
+
+include $(WMLBASE)/Make.lang
+
+
+index.$(LANGUAGE).html: index.wml $(wildcard $(CUR_YEAR)/dsa-*.wml) \
+ $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-*.wml) \
+ $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-*.data) \
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/recent_list.wml
+
+ifndef SUBLANG
+DSARDF := dsa.$(LANGUAGE).rdf
+DESTDSARDF := $(HTMLDIR)/$(DSARDF)
+else
+DSARDF := $(sort $(foreach i,$(SUBLANG),$(subst dsa,dsa.$(LANGUAGE)-$(i),dsa.rdf)))
+DESTDSARDF := $(patsubst %.rdf,$(HTMLDIR)/%.rdf,$(DSARDF))
+endif
+
+$(DSARDF): $(ENGLISHDIR)/security/dsa.rdf.in \
+ $(wildcard $(CUR_YEAR)/dsa-*.wml) \
+ $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.wml) \
+ $(wildcard $(ENGLISHDIR)/security/$(CUR_YEAR)/dsa-*.data) \
+ $(TEMPLDIR)/recent_list.wml
+ifeq "$(LANGUAGE)" "zh"
+ $(shell echo $(WML) | perl -pe 's,:.zh-(..)\.html,:dsa.zh-$$1.rdf,g') \
+ $(shell egrep '^-D (CUR_|CHAR)' ../.wmlrc) \
+ $(ENGLISHDIR)/security/dsa.rdf.in
+ @echo -n " * Converting: [zh_CN.GB2312], "
+ @$(B5TOGB) < dsa.zh-cn.rdf.tmp > dsa.zh-cn.rdf
+ @rm -f dsa.zh-cn.rdf.tmp
+ @$(TOCN) dsa.zh-cn.rdf
+ @echo -n "[zh_HK.Big5], "
+ @mv -f dsa.zh-hk.rdf.tmp dsa.zh-hk.rdf
+ @$(TOHK) dsa.zh-hk.rdf
+ @echo "[zh_TW.Big5]."
+ @mv -f dsa.zh-tw.rdf.tmp dsa.zh-tw.rdf
+ @$(TOTW) dsa.zh-tw.rdf
+else
+ $(WML) $(shell egrep '^-D (CUR_|CHAR)' ../.wmlrc) \
+ $(ENGLISHDIR)/security/dsa.rdf.in
+endif
+
+all:: $(DSARDF)
+
+install:: $(DESTDSARDF)
+
+$(DESTDSARDF): $(HTMLDIR)/%: %
+ install -m 664 -p $< $(HTMLDIR)
+ifeq "$(LANGUAGE)" "en"
+ ln -sf dsa.en.rdf $(HTMLDIR)/dsa.rdf
+endif
+
+ifeq "$(LANGUAGE)" "en"
+install:: $(HTMLDIR)/keys.txt
+
+$(HTMLDIR)/keys.txt: $(HTMLDIR)/%: %
+ install -m 664 -p $< $(HTMLDIR)
+endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy