aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJosip Rodin <joy>2000-07-12 19:10:25 +0000
committerJosip Rodin <joy>2000-07-12 19:10:25 +0000
commitd306da1b0312d7f7401ad30092467b5985235c1b (patch)
tree3ca673b26f83f4a6472932e33fe98e471fbe2f73 /Makefile
parentc08135c13ae78dec0627e361d819e22ca3e145b0 (diff)
let's use some of that make magic
CVS version numbers Makefile: 1.17 -> 1.18
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index bff462246bf..8ce999f722e 100644
--- a/Makefile
+++ b/Makefile
@@ -4,12 +4,14 @@ LANGUAGES := arabic chinese croatian danish dutch english esperanto finnish \
french german hungarian italian japanese korean norwegian \
polish portuguese romanian russian spanish swedish turkish
-.PHONY: default all install
-
-default: install
-
-all:
- for d in ${LANGUAGES}; do $(MAKE) -C $$d; done
+.SUFFIXES:
+.PHONY: install all ${LANGUAGES}
install:
for d in ${LANGUAGES}; do $(MAKE) -C $$d install; done
+
+${LANGUAGES}:
+ ${MAKE} -C $@
+
+all: ${LANGUAGES}
+

© 2014-2024 Faster IT GmbH | imprint | privacy policy