aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJosip Rodin <joy>2000-07-13 01:18:56 +0000
committerJosip Rodin <joy>2000-07-13 01:18:56 +0000
commitad866ee676b5d14543b0b5e231370a1dd51393b5 (patch)
treeb9cf655ac6197423db9141940be5a6fbd3de531f /Makefile
parenta261adf3032e71eaa9a82f347752ac1db5e48322 (diff)
makefile magic for install rule, too
CVS version numbers Makefile: 1.18 -> 1.19
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 8ce999f722e..92f93861d6a 100644
--- a/Makefile
+++ b/Makefile
@@ -3,15 +3,17 @@
LANGUAGES := arabic chinese croatian danish dutch english esperanto finnish \
french german hungarian italian japanese korean norwegian \
polish portuguese romanian russian spanish swedish turkish
+LANGUAGES-install := $(addsuffix -install,${LANGUAGES})
.SUFFIXES:
-.PHONY: install all ${LANGUAGES}
+.PHONY: install all ${LANGUAGES} ${LANGUAGES-install}
-install:
- for d in ${LANGUAGES}; do $(MAKE) -C $$d install; done
-
-${LANGUAGES}:
- ${MAKE} -C $@
+install: ${LANGUAGES-install}
all: ${LANGUAGES}
+${LANGUAGES-install}:
+ ${MAKE} -C $(subst -install,,$@) install
+
+${LANGUAGES}:
+ ${MAKE} -C $@

© 2014-2024 Faster IT GmbH | imprint | privacy policy