aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.common
diff options
context:
space:
mode:
authorJosip Rodin <joy>2008-08-17 00:46:03 +0000
committerJosip Rodin <joy>2008-08-17 00:46:03 +0000
commitd047128e5714a3a4688353b5493a06f089c989f2 (patch)
tree2016465b76c8e5b8bca8ae68e9a8d9dbcc05cd99 /Makefile.common
parent9508f6bb7271e8f6e46bbcf9cf491ccde9d1224b (diff)
added a handy alias for .wmlrc dependencies, also useful elsewhere
CVS version numbers Makefile.common: 1.92 -> 1.93
Diffstat (limited to 'Makefile.common')
-rw-r--r--Makefile.common8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.common b/Makefile.common
index e894bf9d3c2..1997ec0d255 100644
--- a/Makefile.common
+++ b/Makefile.common
@@ -19,6 +19,8 @@ GETTEXTDEP += $(addprefix $(LOCALEDIR)/,$(GETTEXTFILES))
endif
endif
+WMLRCDEP := $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc
+
LANGUAGECAP = $(shell echo $(LANGUAGE) | tr "a-z" "A-Z")
WMLOPTIONS := -q -D CUR_YEAR=$(CUR_YEAR)
WMLOUTFILE = $(@F)
@@ -74,16 +76,16 @@ $(existing-SUBS-cleandest):
# the rule for every wml file
ifndef NOGENERICDEP
ifeq "$(findstring /CD,$(CURDIR))" ""
-%.$(LANGUAGE).html : %.wml $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc \
+%.$(LANGUAGE).html : %.wml $(WMLRCDEP) \
$(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml $(GETTEXTDEP)
$(WML) $(<F)
else
ifeq "$(findstring /CD/vendors,$(CURDIR))" ""
-%.$(LANGUAGE).html : %.wml $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc \
+%.$(LANGUAGE).html : %.wml $(WMLRCDEP) \
$(TEMPLDIR)/cdimage.wml $(GETTEXTDEP)
$(WML) $(<F)
else
-%.$(LANGUAGE).html : %.wml $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc \
+%.$(LANGUAGE).html : %.wml $(WMLRCDEP) \
$(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml $(GETTEXTDEP)
$(WML) $(<F)
endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy