aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.common
diff options
context:
space:
mode:
authorJosip Rodin <joy>2001-08-09 22:32:28 +0000
committerJosip Rodin <joy>2001-08-09 22:32:28 +0000
commitbec839f4588dcbbc87b512d443199d6a699dac67 (patch)
tree6a46b7af09efc039f6a55f5db4cd9d7a5b7fbfb4 /Makefile.common
parent2c9d4483b97ca1a6bbcbf864ef028f61f6ecfd1f (diff)
hey, we can make HTMLDIR a target, and have make run test+mkdir only if it doesn't exist
CVS version numbers Makefile.common: 1.41 -> 1.42
Diffstat (limited to 'Makefile.common')
-rw-r--r--Makefile.common11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.common b/Makefile.common
index c234defe08b..caf73951102 100644
--- a/Makefile.common
+++ b/Makefile.common
@@ -52,9 +52,7 @@ all:: $(HTMLFILES) $(existing-SUBS)
$(existing-SUBS):
-$(MAKE) -C $@
-install::
- test -d $(HTMLDIR) || mkdir -m g+w -p $(HTMLDIR)
-install:: $(HTMLDESTFILES) $(IMGDESTFILES) $(existing-SUBS-install)
+install:: $(HTMLDIR) $(IMGDESTFILES) $(existing-SUBS-install)
$(existing-SUBS-install):
-$(MAKE) -C $(subst -install,,$@) install
@@ -100,8 +98,11 @@ ifneq "$(findstring /international/,$(CURDIR)/)" ""
endif
endif
+$(HTMLDIR):
+ test -d $(HTMLDIR) || mkdir -m g+w -p $(HTMLDIR)
+
ifndef NOGENERICINSTDEP
-$(HTMLDIR)/%.$(LANGUAGE).html: %.$(LANGUAGE).html
+$(HTMLDIR)/%.$(LANGUAGE).html: %.$(LANGUAGE).html $(HTMLDIR)
@echo copying $(@F) to $(HTMLDIR)
-@install -m 664 -p $(@F) $(HTMLDIR)
ifeq ($(LANGUAGE),en)
@@ -110,7 +111,7 @@ ifeq ($(LANGUAGE),en)
endif
endif
-$(IMGDESTFILES): $(HTMLDIR)/%: %
+$(IMGDESTFILES): $(HTMLDIR)/%: % $(HTMLDIR)
install -m 664 -p $< $(HTMLDIR)
ifeq "$(LANGUAGE)" "en"
[ -f "$(HTMLDIR)/$(basename $(basename $<))$(suffix $<)" ] || ln -s $< $(HTMLDIR)/$(basename $(basename $<))$(suffix $<)

© 2014-2024 Faster IT GmbH | imprint | privacy policy