aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.common
diff options
context:
space:
mode:
authorFinnish Language Team <finnish>2001-06-06 08:09:46 +0000
committerFinnish Language Team <finnish>2001-06-06 08:09:46 +0000
commit77f23df7a452a371c616c9eaee7a4297592d5538 (patch)
tree700155bfd6c2543024b187b09eb17aa521295dbc /Makefile.common
parente63d2951d09defc42e960f7a44a32d8993d692f4 (diff)
fixed target for images, not anymore each of $(IMGDESTFILES) depends on every of $(IMGFILES), just the one it is copied from; also removed $(*DESTFILES) and use only $(IMGDESTFILES) as others arent needed
CVS version numbers Makefile.common: 1.35 -> 1.36
Diffstat (limited to 'Makefile.common')
-rw-r--r--Makefile.common18
1 files changed, 5 insertions, 13 deletions
diff --git a/Makefile.common b/Makefile.common
index a5fee4baca0..f9e316c900b 100644
--- a/Makefile.common
+++ b/Makefile.common
@@ -28,26 +28,18 @@ HTMLFILES = $(sort $(foreach i,$(SUBLANG),\
HTMLDESTFILES = $(sort $(foreach i,$(SUBLANG),\
$(patsubst %.wml,$(HTMLDIR)/%.$(LANGUAGE)-$(i).html,$(WMLFILES))))
endif
+
JPGSOURCE := $(wildcard *.jpg)
-JPGDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(JPGSOURCE))
GIFSOURCE := $(wildcard *.gif)
-GIFDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(GIFSOURCE))
PNGSOURCE := $(wildcard *.png)
-PNGDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(PNGSOURCE))
PSSOURCE := $(wildcard *.ps.gz)
-PSDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(PSSOURCE))
EPSSOURCE := $(wildcard *.eps)
-EPSDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(EPSSOURCE))
PDFSOURCE := $(wildcard *.pdf)
-PDFDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(PDFSOURCE))
FIGSOURCE := $(wildcard *.fig)
-FIGDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(FIGSOURCE))
XCFSOURCE := $(wildcard *.xcf.gz)
-XCFDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(XCFSOURCE))
CSSSOURCE := $(wildcard *.css)
-CSSDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(CSSSOURCE))
IMGFILES := $(JPGSOURCE) $(GIFSOURCE) $(PNGSOURCE) $(PSSOURCE) $(EPSSOURCE) $(PDFSOURCE) $(FIGSOURCE) $(XCFSOURCE) $(CSSSOURCE)
-IMGDESTFILES := $(JPGDESTFILES) $(GIFDESTFILES) $(PNGDESTFILES) $(PSDESTFILES) $(EPSDESTFILES) $(PDFDESTFILES) $(FIGDESTFILES) $(XCFDESTFILES) $(CSSDESTFILES)
+IMGDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(IMGFILES))
existing-SUBS := $(shell for dir in $(wildcard $(SUBS)) ''; do test -d $$dir && echo $$dir; done)
existing-SUBS-install := $(addsuffix -install,$(existing-SUBS))
@@ -116,10 +108,10 @@ ifeq ($(LANGUAGE),en)
endif
endif
-$(IMGDESTFILES): $(IMGFILES)
- install -m 664 -p $(@F) $(HTMLDIR)
+$(IMGDESTFILES): $(HTMLDIR)/%: %
+ install -m 664 -p $< $(HTMLDIR)
ifeq "$(LANGUAGE)" "en"
- [ -f "$(HTMLDIR)/$(basename $(basename $(@F)))$(suffix $(@F))" ] || ln -s $(@F) $(HTMLDIR)/$(basename $(basename $(@F)))$(suffix $(@F))
+ [ -f "$(HTMLDIR)/$(basename $(basename $<))$(suffix $<)" ] || ln -s $< $(HTMLDIR)/$(basename $(basename $<))$(suffix $<)
endif
# template dependencies

© 2014-2024 Faster IT GmbH | imprint | privacy policy