aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.common
diff options
context:
space:
mode:
authorDenis Barbier <barbier>2002-11-02 15:39:31 +0000
committerDenis Barbier <barbier>2002-11-02 15:39:31 +0000
commit7269801a954425d537ffe30577e370f639c548b6 (patch)
treedf995613dddc68ca3de6fee17c92fa16a875b177 /Makefile.common
parentff4055b90564d1cb0c5b07d3501896a3d9bde271 (diff)
In dependencies, remove $(HTMLDEP), which was never used, and
add $(GETTEXTDEP). CVS version numbers Makefile.common: 1.66 -> 1.67 chinese/Make.lang: 1.33 -> 1.34
Diffstat (limited to 'Makefile.common')
-rw-r--r--Makefile.common11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.common b/Makefile.common
index adc08ae9fc8..40611f8e784 100644
--- a/Makefile.common
+++ b/Makefile.common
@@ -11,6 +11,11 @@ TEMPLDIR := $(ENGLISHDIR)/template/debian
RELHTMLBASE := ../../www
HTMLDIR = $(WMLBASE)/$(RELHTMLBASE)/$(CUR_DIR)
+LOCALEDIR := $(WMLBASE)/../locale/$(LANGUAGE)/LC_MESSAGES
+ifneq "$(LANGUAGE)" "en"
+GETTEXTDEP := $(LOCALEDIR)/templates.mo
+endif
+
LANGUAGECAP = $(shell echo $(LANGUAGE) | tr "a-z" "A-Z")
WMLOPTIONS := -q -D CUR_YEAR=$(CUR_YEAR)
WMLOUTFILE = $(@F)
@@ -79,16 +84,16 @@ endif
ifndef NOGENERICDEP
ifeq "$(findstring /CD,$(CURDIR))" ""
%.$(LANGUAGE).html : %.wml $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc \
- $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml $(HTMLDEP)
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml $(GETTEXTDEP)
$(WML) $(<F)
else
ifeq "$(findstring /CD/vendors,$(CURDIR))" ""
%.$(LANGUAGE).html : %.wml $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc \
- $(TEMPLDIR)/cdimage.wml $(HTMLDEP)
+ $(TEMPLDIR)/cdimage.wml $(GETTEXTDEP)
$(WML) $(<F)
else
%.$(LANGUAGE).html : %.wml $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc \
- $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml $(HTMLDEP)
+ $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml $(GETTEXTDEP)
$(WML) $(<F)
endif
endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy