aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.common
diff options
context:
space:
mode:
authorJosip Rodin <joy>2002-01-01 00:52:24 +0000
committerJosip Rodin <joy>2002-01-01 00:52:24 +0000
commit69213485f0b948ed38715a4f65ed22fdb0ac9d70 (patch)
tree863c0f8dfbd717db979c095b007166056b9ad55d /Makefile.common
parentb6b0f29649e887caa57df8c473573334903b17c8 (diff)
changes necessary for /CD/images/; ignore errors from touch_translations.pl (otherwise it does exit 255 on every file in every directory not in CVS, which is annoying)
CVS version numbers Makefile.common: 1.51 -> 1.52
Diffstat (limited to 'Makefile.common')
-rw-r--r--Makefile.common12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.common b/Makefile.common
index 3a7ff2c55d7..ecd981fcbbd 100644
--- a/Makefile.common
+++ b/Makefile.common
@@ -30,7 +30,7 @@ HTMLDESTFILES = $(sort $(foreach i,$(SUBLANG),\
endif
OTHERFILES := $(wildcard *.ps.gz *.eps *.pdf *.css)
-OTHERFILES += $(wildcard *.jpg *.gif *.png *.fig *.xcf.gz *.ppm)
+OTHERFILES += $(wildcard *.jpg *.jpeg *.gif *.png *.fig *.xcf.gz *.ppm)
OTHERDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(OTHERFILES))
existing-SUBS := $(shell for dir in $(wildcard $(SUBS)) ''; do test -d $$dir && echo $$dir; done)
@@ -77,16 +77,22 @@ endif
# the rule for every wml file
ifndef NOGENERICDEP
+ifneq "$(findstring /CD/images/,$(CURDIR))" ""
%.$(LANGUAGE).html : %.wml $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc \
$(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml $(HTMLDEP)
$(WML) $(<F)
+else
+%.$(LANGUAGE).html : %.wml $(WMLBASE)/../.wmlrc $(WMLBASE)/.wmlrc \
+ $(TEMPLDIR)/cdimage.wml $(HTMLDEP)
+ $(WML) $(<F)
+endif
ifeq "$(LANGUAGE)" "en"
ifeq "$(findstring /international/,$(CURDIR)/)" ""
- $(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
+ -$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
endif
endif
ifneq "$(findstring /international/,$(CURDIR)/)" ""
- $(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
+ -$(WMLBASE)/../touch_translations.pl $(CURDIR)/$(<F) $(LANGUAGE)
endif
endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy