aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.common
diff options
context:
space:
mode:
authorJosip Rodin <joy>2001-09-02 14:31:54 +0000
committerJosip Rodin <joy>2001-09-02 14:31:54 +0000
commit68075c4ce83309b15c1c51d79d3165dda761f858 (patch)
tree373025efa96ef2bbca9d9c8ba6bfa5b7f762ed04 /Makefile.common
parent4fce58a63f4bbb23c7c2d72e6bbc1e99cd52ec6f (diff)
simplified the code to install other files (i _think_ nothing will break because of this)
CVS version numbers Makefile.common: 1.45 -> 1.46
Diffstat (limited to 'Makefile.common')
-rw-r--r--Makefile.common22
1 files changed, 6 insertions, 16 deletions
diff --git a/Makefile.common b/Makefile.common
index d4f4b4f5c93..2112e167739 100644
--- a/Makefile.common
+++ b/Makefile.common
@@ -29,20 +29,9 @@ HTMLDESTFILES = $(sort $(foreach i,$(SUBLANG),\
$(patsubst %.wml,$(HTMLDIR)/%.$(LANGUAGE)-$(i).html,$(WMLFILES))))
endif
-JPGSOURCE := $(wildcard *.jpg)
-GIFSOURCE := $(wildcard *.gif)
-PNGSOURCE := $(wildcard *.png)
-PSSOURCE := $(wildcard *.ps.gz)
-EPSSOURCE := $(wildcard *.eps)
-PDFSOURCE := $(wildcard *.pdf)
-FIGSOURCE := $(wildcard *.fig)
-XCFSOURCE := $(wildcard *.xcf.gz)
-CSSSOURCE := $(wildcard *.css)
-CSSDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(CSSSOURCE))
-PPMSOURCE := $(wildcard *.ppm)
-PPMDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(PPMSOURCE))
-IMGFILES := $(JPGSOURCE) $(GIFSOURCE) $(PNGSOURCE) $(PSSOURCE) $(EPSSOURCE) $(PDFSOURCE) $(FIGSOURCE) $(XCFSOURCE) $(CSSSOURCE) $(PPMSOURCE)
-IMGDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(IMGFILES))
+OTHERFILES := $(wildcard *.ps.gz *.eps *.pdf *.css)
+OTHERFILES += $(wildcard *.jpg *.gif *.png *.fig *.xcf.gz *.ppm)
+OTHERDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(OTHERFILES))
existing-SUBS := $(shell for dir in $(wildcard $(SUBS)) ''; do test -d $$dir && echo $$dir; done)
existing-SUBS-install := $(addsuffix -install,$(existing-SUBS))
@@ -55,7 +44,7 @@ all:: $(HTMLFILES) $(existing-SUBS)
$(existing-SUBS):
-$(MAKE) -C $@
-install:: $(HTMLDESTFILES) $(IMGDESTFILES) $(existing-SUBS-install)
+install:: $(HTMLDESTFILES) $(OTHERDESTFILES) $(existing-SUBS-install)
$(existing-SUBS-install):
-$(MAKE) -C $(subst -install,,$@) install
@@ -112,10 +101,11 @@ ifeq ($(LANGUAGE),en)
endif
endif
-$(IMGDESTFILES): $(HTMLDIR)/%: %
+$(OTHERDESTFILES): $(HTMLDIR)/%: %
@test -d $(HTMLDIR) || mkdir -m g+w -p $(HTMLDIR)
install -m 664 -p $< $(HTMLDIR)
ifeq "$(LANGUAGE)" "en"
+# probably doesn't work for *.gz files, FIXME
[ -f "$(HTMLDIR)/$(basename $(basename $<))$(suffix $<)" ] || ln -s $< $(HTMLDIR)/$(basename $(basename $<))$(suffix $<)
endif

© 2014-2024 Faster IT GmbH | imprint | privacy policy