aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.common
diff options
context:
space:
mode:
authorJosip Rodin <joy>2001-08-14 16:45:03 +0000
committerJosip Rodin <joy>2001-08-14 16:45:03 +0000
commit536de1dd03fb99522426d5ffae93149c325cc341 (patch)
treef0c5a103f9723bd190fbbc46e5e7865102ea4d6e /Makefile.common
parenta5d1876efce7d74185f381ed1afdf714d8ab925a (diff)
depending on HTMLDIR is wrong, because make not only checks for its existence, it checks for its date, and we don't want that. just silently test for it in the install file rules, that's nicer, even though a bit more resource wasteful (all those stat()s or something :)
CVS version numbers Makefile.common: 1.43 -> 1.44 english/News/weekly/Makefile: 1.37 -> 1.38
Diffstat (limited to 'Makefile.common')
-rw-r--r--Makefile.common11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile.common b/Makefile.common
index 4b500a867a6..cf202d5cd43 100644
--- a/Makefile.common
+++ b/Makefile.common
@@ -52,7 +52,7 @@ all:: $(HTMLFILES) $(existing-SUBS)
$(existing-SUBS):
-$(MAKE) -C $@
-install:: $(HTMLDIR) $(HTMLDESTFILES) $(IMGDESTFILES) $(existing-SUBS-install)
+install:: $(HTMLDESTFILES) $(IMGDESTFILES) $(existing-SUBS-install)
$(existing-SUBS-install):
-$(MAKE) -C $(subst -install,,$@) install
@@ -98,11 +98,9 @@ ifneq "$(findstring /international/,$(CURDIR)/)" ""
endif
endif
-$(HTMLDIR):
- test -d $(HTMLDIR) || mkdir -m g+w -p $(HTMLDIR)
-
ifndef NOGENERICINSTDEP
-$(HTMLDIR)/%.$(LANGUAGE).html: %.$(LANGUAGE).html $(HTMLDIR)
+$(HTMLDIR)/%.$(LANGUAGE).html: %.$(LANGUAGE).html
+ @test -d $(HTMLDIR) || mkdir -m g+w -p $(HTMLDIR)
@echo copying $(@F) to $(HTMLDIR)
-@install -m 664 -p $(@F) $(HTMLDIR)
ifeq ($(LANGUAGE),en)
@@ -111,7 +109,8 @@ ifeq ($(LANGUAGE),en)
endif
endif
-$(IMGDESTFILES): $(HTMLDIR)/%: % $(HTMLDIR)
+$(IMGDESTFILES): $(HTMLDIR)/%: %
+ @test -d $(HTMLDIR) || mkdir -m g+w -p $(HTMLDIR)
install -m 664 -p $< $(HTMLDIR)
ifeq "$(LANGUAGE)" "en"
[ -f "$(HTMLDIR)/$(basename $(basename $<))$(suffix $<)" ] || ln -s $< $(HTMLDIR)/$(basename $(basename $<))$(suffix $<)

© 2014-2024 Faster IT GmbH | imprint | privacy policy