aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.common
diff options
context:
space:
mode:
authorJosip Rodin <joy>2003-07-28 20:30:50 +0000
committerJosip Rodin <joy>2003-07-28 20:30:50 +0000
commit3a845b8b4c61f206a00ac1ca0bb8d8951ca33b6f (patch)
tree04557dbae03cebd9f1e932b218676777c887b7b5 /Makefile.common
parent284c6d981aea5e9ac461a30a09a5991c644f4f07 (diff)
use patsubst instead of subst to avoid breaking directories called foo-installbar, noticed by Geert Stappers
CVS version numbers Makefile.common: 1.78 -> 1.79
Diffstat (limited to 'Makefile.common')
-rw-r--r--Makefile.common6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.common b/Makefile.common
index b4e40c6b2f0..dabd740be34 100644
--- a/Makefile.common
+++ b/Makefile.common
@@ -55,21 +55,21 @@ $(existing-SUBS):
install:: $(HTMLDESTFILES) $(OTHERDESTFILES) $(existing-SUBS-install)
$(existing-SUBS-install):
- -$(MAKE) -C $(subst -install,,$@) install
+ -$(MAKE) -C $(patsubst %-install,%,$@) install
clean::
rm -f *.$(LANGUAGE).html *~ *.forced
clean:: $(existing-SUBS-clean)
$(existing-SUBS-clean):
- -$(MAKE) -C $(subst -clean,,$@) clean
+ -$(MAKE) -C $(patsubst %-clean,%,$@) clean
cleandest::
rm -f $(HTMLDIR)/*.$(LANGUAGE).html
cleandest:: $(existing-SUBS-cleandest)
$(existing-SUBS-cleandest):
- -$(MAKE) -C $(subst -cleandest,,$@) cleandest
+ -$(MAKE) -C $(patsubst %-cleandest,%,$@) cleandest
# subdirectories of News, events and security dirs each have
# their own generic wml file deps

© 2014-2024 Faster IT GmbH | imprint | privacy policy