aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames A. Treacy <treacy>1998-11-24 23:54:31 +0000
committerJames A. Treacy <treacy>1998-11-24 23:54:31 +0000
commitf582dd192f71f8ddf233049eef011df51a18b68a (patch)
tree1f48ace50482b12bc9ddf5d7cd1d0a02b25ee278
parent323d52a91e7553f4f6b071b38208e01b05087c1b (diff)
added Makefiles so global make works properly
CVS version numbers danish/Make.common: INITIAL -> 1.1 danish/Make.dep.generic: INITIAL -> 1.1 danish/Make.dep.templ: INITIAL -> 1.1 danish/Make.lang: INITIAL -> 1.1 danish/Makefile: INITIAL -> 1.1
-rw-r--r--danish/Make.common65
-rw-r--r--danish/Make.dep.generic2
-rw-r--r--danish/Make.dep.templ28
-rw-r--r--danish/Make.lang21
-rw-r--r--danish/Makefile23
5 files changed, 139 insertions, 0 deletions
diff --git a/danish/Make.common b/danish/Make.common
new file mode 100644
index 00000000000..a092db65956
--- /dev/null
+++ b/danish/Make.common
@@ -0,0 +1,65 @@
+# Nothing in here should require any modification
+# If you feel you need to modify something send mail
+# to debian-www explaining why so that others can benefit
+# from your improvements
+
+RELHTMLBASE=../../debian.org
+RELTEMPLDIR=template/debian
+
+HTMLDIR=$(WMLBASE)/$(RELHTMLBASE)/$(CUR_DIR)
+TEMPLDIR=$(WMLBASE)/$(RELTEMPLDIR)
+# Do Not modify the following line
+ENGLISHSRCDIR=$(WMLBASE)/../english
+
+WMLFILES := $(wildcard *.wml)
+HTMLFILES := $(patsubst %.wml,%.html.$(LANGUAGE),$(WMLFILES))
+HTMLDESTFILES := $(patsubst %.wml,$(HTMLDIR)/%.html.$(LANGUAGE),$(WMLFILES))
+JPGSOURCE := $(wildcard *.jpg)
+JPGDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(JPGSOURCE))
+GIFSOURCE := $(wildcard *.gif)
+GIFDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(GIFSOURCE))
+IMGFILES := $(JPGSOURCE) $(GIFSOURCE)
+IMGDESTFILES := $(JPGDESTFILES) $(GIFDESTFILES)
+
+all:: $(HTMLFILES)
+ @for i in $(SUBS) ''; do \
+ if [ -d "$$i" ]; then \
+ $(MAKE) -C $$i ; \
+ fi ; \
+ done
+
+install::
+ -install -d $(HTMLDIR)
+install:: $(HTMLDESTFILES) $(IMGDESTFILES)
+ @for i in $(SUBS) ''; do \
+ if [ -d "$$i" ]; then \
+ $(MAKE) -C $$i install; \
+ fi ; \
+ done
+
+clean::
+ -rm -f *.html.$(LANGUAGE)
+ @for i in $(SUBS) ''; do \
+ if [ -d "$$i" ]; then \
+ $(MAKE) -C $$i clean; \
+ fi ; \
+ done
+
+cleandest::
+ -rm -f $(HTMLDIR)/*.html.$(LANGUAGE)
+ @for i in $(SUBS) ''; do \
+ if [ -d "$$i" ]; then \
+ $(MAKE) -C $$i clean; \
+ fi ; \
+ done
+
+$(HTMLDIR)/%.html.$(LANGUAGE): %.html.$(LANGUAGE)
+ @echo copying $(@F) to $(HTMLDIR)
+ -@cp $(@F) $(HTMLDIR)
+ifeq ($(LANGUAGE),en)
+ @echo making a link $(@D)/$(*F).html -\> $(@F)
+ -@ln -f -s $(@F) $(@D)/$(*F).html
+endif
+
+$(IMGDESTFILES):
+ cp $(@F) $(HTMLDIR)
diff --git a/danish/Make.dep.generic b/danish/Make.dep.generic
new file mode 100644
index 00000000000..8ff0e3a89c7
--- /dev/null
+++ b/danish/Make.dep.generic
@@ -0,0 +1,2 @@
+%.html.$(LANGUAGE) : %.wml $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml
+ $(WML) $(<F)
diff --git a/danish/Make.dep.templ b/danish/Make.dep.templ
new file mode 100644
index 00000000000..1de7ea0fd4f
--- /dev/null
+++ b/danish/Make.dep.templ
@@ -0,0 +1,28 @@
+# template dependencies
+
+$(TEMPLDIR)/basic.wml: $(TEMPLDIR)/navbar.wml
+ touch $(TEMPLDIR)/basic.wml
+
+$(TEMPLDIR)/footer.wml: $(TEMPLDIR)/ctime.wml
+ touch $(TEMPLDIR)/footer.wml
+
+$(TEMPLDIR)/menubar.wml: $(TEMPLDIR)/footer.wml
+ touch $(TEMPLDIR)/menubar.wml
+
+$(TEMPLDIR)/mainpage.wml: $(TEMPLDIR)/basic.wml $(TEMPLDIR)/menubar.wml
+ touch $(TEMPLDIR)/mainpage.wml
+
+$(TEMPLDIR)/template.wml: $(TEMPLDIR)/basic.wml $(TEMPLDIR)/footer.wml \
+ $(TEMPLDIR)/languages.wml
+ touch $(TEMPLDIR)/template.wml
+
+$(TEMPLDIR)/news.wml: $(TEMPLDIR)/basic.wml $(TEMPLDIR)/footer.wml \
+ $(TEMPLDIR)/languages.wml
+ touch $(TEMPLDIR)/news.wml
+
+$(TEMPLDIR)/consultant.wml: $(TEMPLDIR)/footer.wml
+ touch $(TEMPLDIR)/consultant.wml
+
+$(TEMPLDIR)/event.wml: $(TEMPLDIR)/footer.wml $(TEMPLDIR)/languages.wml $(TEMPLDIR)/basic.wml
+ touch $(TEMPLDIR)/event.wml
+
diff --git a/danish/Make.lang b/danish/Make.lang
new file mode 100644
index 00000000000..305a77d37ec
--- /dev/null
+++ b/danish/Make.lang
@@ -0,0 +1,21 @@
+# The LANGUAGE variable needs to be set for each language.
+# LANGUAGECAP is just the capitalization of LANGUAGE (this is needed for wml slices)
+LANGUAGE=da
+LANGUAGECAP=DA
+
+# The '-q' forces wml to be quiet. Very useful in scripts.
+# It is sometimes useful to add '--epilog=weblint' to check for errors
+# in the html generated.
+# Other languages may want to change the wml command to execute programs
+# that get run before or after wml. For example,
+# WML="wml -q --prolog="/usr/bin/tcs <options here>" \
+# --epilog="/usr/bin/tcs <options here> > $(@D)/$(@F)" \
+# -o $(@F)
+# If you use --epilog as above, then you will want to add a line to
+# Make.templ.inc to remove $(@F) after WML is done.
+WMLOPTIONS=-q
+WMLOUTFILE=$(@F)
+WMLPROLOG=
+WMLEPILOG=
+WML=wml $(WMLOPTIONS) -o $(WMLOUTFILE) $(WMLPROLOG) $(WMLEPILOG)
+
diff --git a/danish/Makefile b/danish/Makefile
new file mode 100644
index 00000000000..0eb6889474d
--- /dev/null
+++ b/danish/Makefile
@@ -0,0 +1,23 @@
+# This Makefile should need no changes from webwml/english/Makefile
+# Please send a message to debian-www if you need to modify anything
+# so the problem can be fixed.
+
+WMLBASE=.
+CUR_DIR=
+# list any subdirectories in the following variable. Any directories listed
+# must exist or the make will not work
+SUBS=2.0 MailingLists News SPI devel distrib doc events intro logos mirror \
+ports security Pics
+
+include $(WMLBASE)/Make.lang
+include $(WMLBASE)/Make.common
+
+include $(WMLBASE)/Make.dep.generic
+include $(WMLBASE)/Make.dep.templ
+
+# Do Not modify the following line
+index.html.$(LANGUAGE): index.wml $(TEMPLDIR)/mainpage.wml \
+ $(wildcard News/1998/1998*.wml) $(wildcard $(ENGLISHSRCDIR)/News/1998/1998*.wml) \
+ $(TEMPLDIR)/ctime.wml $(TEMPLDIR)/recent_list.wml $(TEMPLDIR)/languages.wml
+ $(WML) index.wml
+

© 2014-2024 Faster IT GmbH | imprint | privacy policy