aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lange <lange@debian.org>2020-10-16 11:28:05 +0200
committerThomas Lange <lange@debian.org>2020-10-16 11:28:05 +0200
commite2c286229cb11dac948a8b7e68f46c5ae7383343 (patch)
treea72b7b18231d8f4b66cf40c230aed2c5a9abcbfa
parent68009512695f4646ba69e34d38d71df82b6cff5b (diff)
rename topnews to homepagenews
-rw-r--r--english/Makefile2
-rw-r--r--english/homepagenews.data (renamed from english/topnews.data)0
-rw-r--r--english/template/debian/recent_list.wml8
3 files changed, 5 insertions, 5 deletions
diff --git a/english/Makefile b/english/Makefile
index ee060abf169..0326e02650d 100644
--- a/english/Makefile
+++ b/english/Makefile
@@ -29,7 +29,7 @@ DESTSEARCHXML = $(patsubst %.xml,$(HTMLDIR)/%.xml,$(SEARCHXML))
endif
$(INDEXPAGE): index.wml $(ENGLISHSRCDIR)/index.def $(ENGLISHSRCDIR)/index.inc $(TEMPLDIR)/mainpage.wml $(GETTEXTDEP) \
- $(ENGLISHSRCDIR)/topnews.data \
+ $(ENGLISHSRCDIR)/homepagenews.data \
$(wildcard News/$(CUR_YEAR)/[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/News/$(CUR_YEAR)/[0-9]*.wml) \
$(wildcard News/$(CUR_YEAR)/[0-9]*.title) \
$(wildcard security/$(CUR_YEAR)/dsa-[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-[0-9]*.wml) \
diff --git a/english/topnews.data b/english/homepagenews.data
index 941df64f397..941df64f397 100644
--- a/english/topnews.data
+++ b/english/homepagenews.data
diff --git a/english/template/debian/recent_list.wml b/english/template/debian/recent_list.wml
index 65d13fc5dd4..49f76abeb50 100644
--- a/english/template/debian/recent_list.wml
+++ b/english/template/debian/recent_list.wml
@@ -40,13 +40,13 @@
<perl>
# get_top_news()
-# display the top news selected by topnews.data
-# each line in topnews.data contains one file filename (without .wml) of some news
+# display the top news selected by homepagenews.data
+# each line in homepagenews.data contains one file filename (without .wml) of some news
# we use the frontpage format for a nice layout
sub get_top_news() {
- open DATAFILE, "$(ENGLISHDIR)/topnews.data" or warn "couldn't open $(ENGLISHDIR)/$topnews.data: $!\n";
- # read list of topnews
+ open DATAFILE, "$(ENGLISHDIR)/homepagenews.data" or warn "couldn't open $(ENGLISHDIR)/$homepagenews.data: $!\n";
+ # read list of homepagenews
foreach my $id (<DATAFILE>) {
chomp $id;
print get_recent_list('News/2y', '1', '$(ENGLISHDIR)', 'bydate frontpage', $id);

© 2014-2024 Faster IT GmbH | imprint | privacy policy