aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastiano Pistore <SebastianoPistore.info@protonmail.ch>2019-06-10 11:31:07 +0200
committerSebastiano Pistore <SebastianoPistore.info@protonmail.ch>2019-06-10 11:31:07 +0200
commit6b99646644baee856b0f8bc2600186bc0038ae22 (patch)
treef9a4651c0f82f8715b35a3720bfa4bd719e1b752
parent2ee4e7c4360ff88e145af69ce679d92e606c3691 (diff)
Fixed small English syntax errors.
The executable code has NOT been modified.
-rw-r--r--README2
-rwxr-xr-xcheck_desc_trans.pl2
-rwxr-xr-xcheck_trans.pl16
-rwxr-xr-xcopypage.pl2
-rwxr-xr-xswitch_to_git_translations.pl2
5 files changed, 12 insertions, 12 deletions
diff --git a/README b/README
index 8c80643698d..30ba754638a 100644
--- a/README
+++ b/README
@@ -31,7 +31,7 @@ Translations:
* opencc (Chinese translation conversions)
-You can find a comprenhensive list of packages that needs to be installed
+You can find a comprehensive list of packages that needs to be installed
to complete build the Debian website in the recipe used for www-master.debian.org:
https://salsa.debian.org/dsa-team/mirror/debian.org/blob/master/debian/control
diff --git a/check_desc_trans.pl b/check_desc_trans.pl
index c29e9f448b0..9276fa9fcb0 100755
--- a/check_desc_trans.pl
+++ b/check_desc_trans.pl
@@ -123,7 +123,7 @@ sub read_transcheck
{
my $dir = shift or die("No directory specified");
- # get a listof all translation-check files
+ # get a list of all translation-check files
my @files = File::Find::Rule->file()->name('translation-check')->in($dir);
my %info;
diff --git a/check_trans.pl b/check_trans.pl
index 466d592d7d0..7b513b83a60 100755
--- a/check_trans.pl
+++ b/check_trans.pl
@@ -78,7 +78,7 @@
# USAGE:
# If you give the "-g" option, all mails are written to the console. No
# mails are sent out at all. This is useful for debugging.
-# If you specify an email addres with the "-M" options, all mails are sent
+# If you specify an email address with the "-M" options, all mails are sent
# to the specified addressee. No mails are sent to any other addresses. It
# is useful if you want to run it for yourself.
# Without either of these options, real mails will be sent to real
@@ -423,7 +423,7 @@ die("Never reached");
#=================================================
-#== swich two variables around
+#== switch two variables around
#==
sub switch_var(\$\$)
{
@@ -479,7 +479,7 @@ sub send_email
my $subject;
my $mailbody;
- # First handle the case in whcih all mail goes to the -M address
+ # First handle the case in which all mail goes to the -M address
if ( $default_rec )
{
# address was already validated while parsing the command line
@@ -487,7 +487,7 @@ sub send_email
$subject = $DEFAULT_SUBJECT;
$mailbody = $DEFAULT_BODY;
}
- else # handle the case in whcih addresses are fetch from the db
+ else # handle the case in which addresses are fetch from the db
{
# skip unconfigured users
if ( not exists $translators->{$name}
@@ -497,7 +497,7 @@ sub send_email
next;
}
- # check the user's email addres
+ # check the user's email address
if ( not Email::Address->parse( $translators->{$name}{'email'} ) )
{
printf STDERR "Can't parse email address `%s' for %s!\n",
@@ -520,7 +520,7 @@ sub send_email
$mailbody = read_file_enc( $translators->{'default'}{'mailbody'} )
or die("Can't read $translators->{'default'}{'mailbody'}");
{
- # a bit hackish, but I want to keep the curent format of
+ # a bit hackish, but I want to keep the current format of
# the mail body files intact, for now
# so we need to use the same old variable names as the original
# script used
@@ -818,7 +818,7 @@ sub get_diff_txt
# Get translation file
my $transl_txt = read_file( $transl_file )
- or die("Couln't read `$transl_file': $!");
+ or die("Couldn't read `$transl_file': $!");
my @transl_txt = split( "\n", $transl_txt );
# Get diff lines
@@ -956,7 +956,7 @@ sub parse_cmdargs
else
{
die "You specified -m (send mails), but you didn't specify "
- ."either -n or -M, so I don't knwo where to send my mails\n";
+ ."either -n or -M, so I don't know where to send my mails\n";
}
}
diff --git a/copypage.pl b/copypage.pl
index 145e18e0da5..3b0e408bb39 100755
--- a/copypage.pl
+++ b/copypage.pl
@@ -135,7 +135,7 @@ sub copy
my $srcdir = $srcfile;
$srcdir =~ s[(.*/).*][$1]; # Source directory (trailing /)
my $dstdir = $dstfile;
- $dstdir =~ s[(.*/).*][$1]; # Desination directory (trailing /)
+ $dstdir =~ s[(.*/).*][$1]; # Destination directory (trailing /)
my $filename = $srcfile;
$filename =~ s[$srcdir][]; # Pathless filename
diff --git a/switch_to_git_translations.pl b/switch_to_git_translations.pl
index 3e6ca8ff39a..2e6ab5f8784 100755
--- a/switch_to_git_translations.pl
+++ b/switch_to_git_translations.pl
@@ -2,7 +2,7 @@
# This script walks the webwml tree to look for translated files. It
# looks for the wml::debian::translation-check header to see if a file
-# is a stranslation of an original, then checks for the revision
+# is a translation of an original, then checks for the revision
# status of the master document.
#
# Part of the effort to switch from CVS to Git

© 2014-2024 Faster IT GmbH | imprint | privacy policy