summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <pochu@debian.org>2023-12-12 16:36:31 +0100
committerEmilio Pozuelo Monfort <pochu@debian.org>2023-12-12 16:39:13 +0100
commitd7e47aa04024736d12cb721bbbc5dabd3bbde669 (patch)
tree027b3c7f4cdd313fbdaa89c23259beb727073762 /Makefile
parent21a3006c997f1cfc82070b9450a0eefd49f23ce4 (diff)
Makefile: add an update-cve-descriptions target
This will be used by the tracker service instead of the update-nvd one, which will be removed later.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f866264939..5da44a5bd0 100644
--- a/Makefile
+++ b/Makefile
@@ -72,12 +72,15 @@ update-backports: $(foreach release,$(BACKPORT_RELEASES),update-$(release)_backp
supported-update-targets:
@echo -n "main security backports "
@echo -n "$(RELEASES) "
- @echo -n "packages lists nvd"
+ @echo -n "packages lists cve-descriptions nvd"
# Other custom update rules
update-lists:
git fetch -q origin && git checkout -f origin/master -- data
+update-cve-descriptions:
+ bin/update-cve-descriptions
+
# Since October 16, 2015 the XML data feeds are no longer available for
# download in an uncompressed format.
# As per October 16, 2019, the XML data feeds were discontinued and NVD
@@ -102,4 +105,4 @@ update-compare-nvd:
done
bin/compare-nvd-cve 2> compare-nvd-cve.log
-update-all: update-nvd update-lists update-packages all
+update-all: update-cve-descriptions update-lists update-packages all

© 2014-2024 Faster IT GmbH | imprint | privacy policy