summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFlorian Weimer <fw@deneb.enyo.de>2007-04-08 21:47:10 +0000
committerFlorian Weimer <fw@deneb.enyo.de>2007-04-08 21:47:10 +0000
commite04d3afc8149bd119cd5214365411057afb4e25e (patch)
tree0fdc2622025969494220bb57ce2312afde6f1ebb /Makefile
parent3704c20afbd095507f88e6371ea392cef4579855 (diff)
First round of adjustments for the etch release
git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@5635 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index 0137aa1577..2d4bad5c31 100644
--- a/Makefile
+++ b/Makefile
@@ -7,8 +7,8 @@ BUG_LISTS = $(wildcard data/*/list)
# MIRROR = http://merkel.debian.org/~aba/debian/
MIRROR = http://ftp-stud.fht-esslingen.de/debian/
-SARGE_ARCHS = alpha arm hppa i386 ia64 m68k mips mipsel powerpc s390 sparc
-ETCH_ARCHS = $(SARGE_ARCHS) amd64
+SARGE_ARCHS = alpha amd64 arm hppa i386 ia64 m68k mips mipsel powerpc s390 sparc
+LENNY_ARCHS = alpha arm hppa i386 ia64 mips mipsel powerpc s390 sparc
all:
rm -f data/security-new.db data/security-new.db.journal
@@ -39,8 +39,8 @@ stamps/DTSA-syntax: data/DTSA/list bin/check-syntax $(PYTHON_MODULES)
$(PYTHON) bin/check-syntax DTSA data/DTSA/list
touch $@
-.PHONY: update-packages update-etch-security
-RELEASES = etch sid
+.PHONY: update-packages update-testing-security
+RELEASES = lenny sid
update-packages:
set -e ; for rel in $(RELEASES) ; do \
for archive in main contrib non-free ; do \
@@ -48,7 +48,7 @@ update-packages:
$(MIRROR)/dists/$$rel/$$archive/source/Sources \
data/packages/$${rel}__$${archive}_Sources ; \
done ; \
- for arch in $(ETCH_ARCHS) ; do \
+ for arch in $(LENNY_ARCHS) ; do \
for archive in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
$(MIRROR)/dists/$$rel/$$archive/binary-$$arch/Packages \
@@ -57,24 +57,24 @@ update-packages:
done ; \
done
-ST_MIRROR = http://security.debian.org/dists/etch/updates
-ST_FILE = data/packages/etch_security_
+ST_MIRROR = http://security.debian.org/dists/lenny/updates
+ST_FILE = data/packages/lenny_security_
update-testing-security:
$(PYTHON) bin/apt-update-file \
$(ST_MIRROR)/main/source/Sources $(ST_FILE)main_Sources
- set -e ; for arch in $(ETCH_ARCHS) ; do \
+ set -e ; for arch in $(LENNY_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
$(ST_MIRROR)/main/binary-$${arch}/Packages $(ST_FILE)main_$${arch}_Packages ; \
done
SEC_MIRROR = http://security.debian.org/dists
update-security:
- for archive in woody sarge ; do \
+ for archive in sarge etch ; do \
for section in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
$(SEC_MIRROR)/$$archive/updates/$$section/source/Sources \
data/packages/$${archive}_security_$${section}_Sources ; \
- for arch in $(ETCH_ARCHS) ; do \
+ for arch in $(SARGE_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
$(SEC_MIRROR)/$$archive/updates/$$section/binary-$$arch/Packages \
data/packages/$${archive}_security_$${section}_$${arch}_Packages ; \
@@ -84,7 +84,7 @@ update-security:
VOLATILE_MIRROR = http://volatile.debian.net/debian-volatile/dists
update-volatile:
- set -e && for arch in $(ETCH_ARCHS) ; do \
+ set -e && for arch in $(LENNY_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
$(VOLATILE_MIRROR)/sarge/volatile/main/binary-$$arch/Packages \
data/packages/sarge_volatile_main_$${arch}_Packages ; \

© 2014-2024 Faster IT GmbH | imprint | privacy policy