summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFlorian Weimer <fw@deneb.enyo.de>2005-09-29 12:39:03 +0000
committerFlorian Weimer <fw@deneb.enyo.de>2005-09-29 12:39:03 +0000
commit86ab49c0e168d6db5ef0c3d8efd1794c2c003ddb (patch)
tree5ccf9c5982aad386e78b40aa9ea65614e5e64595 /Makefile
parentf46428a3b83c95839ff87b04c9eca57eda533a3a (diff)
Makefile:
Update. ("make check" should work out-of-the box and checks for syntax errors in the data/*/list files.) git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@2224 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/Makefile b/Makefile
index 1129bed9f5..adeaa99a1c 100644
--- a/Makefile
+++ b/Makefile
@@ -6,19 +6,12 @@ BUG_LISTS = $(wildcard data/*/list)
# arbitrary at the moment. More architectures can be added later.
MIRROR = http://merkel.debian.org/~aba/debian/
-RELEASES_with_proposed_updates = sarge=i386,ia64 etch=i386,ia64
-RELEASES = sid=i386,ia64 $(RELEASES_with_proposed_updates) \
- $(subst =,-proposed-updates=, $(RELEASES_with_proposed_updates)) \
- woody=i386
-SECURITY_RELEASES = sarge-security=i386,ia64 woody-security=i386
-PACKAGE_FILES = $(wildcard data/packages/*_Sources) \
- $(wildcard data/packages/*_Packages)
all:
$(PYTHON) bin/update-db
clean:
- -rm data/security.db
+ -rm data/security.db lib/python/test_security.db
-rm stamps/*-*
.PHONY: check check-syntax
@@ -45,14 +38,15 @@ stamps/DTSA-syntax: data/DTSA/list bin/check-syntax $(PYTHON_MODULES)
touch $@
.PHONY: update-packages update-etch-security
+RELEASES = sarge etch sid
update-packages:
- set -e ; for rel in woody sarge etch sid ; do \
+ set -e ; for rel in $(RELEASES) ; do \
for archive in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
$(MIRROR)/dists/$$rel/$$archive/source/Sources \
data/packages/$${rel}__$${archive}_Sources ; \
done ; \
- for arch in i386 ia64 ; do \
+ for arch in i386 ia64 alpha powerpc ; do \
for archive in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
$(MIRROR)/dists/$$rel/$$archive/binary-$$arch/Packages \
@@ -60,7 +54,6 @@ update-packages:
done ; \
done ; \
done
- touch stamps/packages-downloaded
ST_MIRROR = http://secure-testing.debian.net/debian-secure-testing/dists/etch/security-updates
ST_FILE = data/packages/etch_security_
@@ -71,6 +64,10 @@ update-testing-security:
$(ST_MIRROR)/main/binary-i386/Packages $(ST_FILE)main_i386_Packages
$(PYTHON) bin/apt-update-file \
$(ST_MIRROR)/main/binary-ia64/Packages $(ST_FILE)main_ia64_Packages
+ $(PYTHON) bin/apt-update-file \
+ $(ST_MIRROR)/main/binary-alpha/Packages $(ST_FILE)main_alpha_Packages
+ $(PYTHON) bin/apt-update-file \
+ $(ST_MIRROR)/main/binary-powerpc/Packages $(ST_FILE)main_powerpc_Packages
SEC_MIRROR = http://security.debian.org/dists
update-security:
@@ -78,7 +75,7 @@ update-security:
$(PYTHON) bin/apt-update-file \
$(SEC_MIRROR)/$$archive/updates/main/source/Sources \
data/packages/$${archive}_security_main_Sources ; \
- for arch in i386 ia64 ; do \
+ for arch in i386 ia64 alpha powerpc ; do \
$(PYTHON) bin/apt-update-file \
$(SEC_MIRROR)/$$archive/updates/main/binary-$$arch/Packages \
data/packages/$${archive}_security_main_$${arch}_Packages ; \

© 2014-2024 Faster IT GmbH | imprint | privacy policy