summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFlorian Weimer <fw@deneb.enyo.de>2006-09-16 17:42:00 +0000
committerFlorian Weimer <fw@deneb.enyo.de>2006-09-16 17:42:00 +0000
commit215325e87bbbbfdf0746b1de03b74d028d0178de (patch)
tree60cc1fa2a3e2b1f61e64dbdf95fdba8e5d967770 /Makefile
parent759a2c5b777f0d82fb105858c835cd26404ff21d (diff)
The secure-testing archive is now on security.debian.org.
stable-security sometimes includes non-free, so we process non-free as well. git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@4731 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index e1aa8f37e9..0137aa1577 100644
--- a/Makefile
+++ b/Makefile
@@ -57,7 +57,7 @@ update-packages:
done ; \
done
-ST_MIRROR = http://secure-testing.debian.net/debian-secure-testing/dists/etch/security-updates
+ST_MIRROR = http://security.debian.org/dists/etch/updates
ST_FILE = data/packages/etch_security_
update-testing-security:
$(PYTHON) bin/apt-update-file \
@@ -70,13 +70,15 @@ update-testing-security:
SEC_MIRROR = http://security.debian.org/dists
update-security:
for archive in woody sarge ; do \
- $(PYTHON) bin/apt-update-file \
- $(SEC_MIRROR)/$$archive/updates/main/source/Sources \
- data/packages/$${archive}_security_main_Sources ; \
- for arch in $(ETCH_ARCHS) ; do \
+ for section in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
- $(SEC_MIRROR)/$$archive/updates/main/binary-$$arch/Packages \
- data/packages/$${archive}_security_main_$${arch}_Packages ; \
+ $(SEC_MIRROR)/$$archive/updates/$$section/source/Sources \
+ data/packages/$${archive}_security_$${section}_Sources ; \
+ for arch in $(ETCH_ARCHS) ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(SEC_MIRROR)/$$archive/updates/$$section/binary-$$arch/Packages \
+ data/packages/$${archive}_security_$${section}_$${arch}_Packages ; \
+ done ; \
done ; \
done

© 2014-2024 Faster IT GmbH | imprint | privacy policy