aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaura Arjona Reina <larjona@debian.org>2019-03-16 18:56:21 +0100
committerLaura Arjona Reina <larjona@debian.org>2019-03-16 18:56:21 +0100
commit0d564da44aaec3d4504aada1d5db8985d294932d (patch)
treed49c9ad49ef340769de7bf88844d9add30defc3a
parentfbe8d242c2aadcb6cd74c47d8cd52c204aeaf1b1 (diff)
add templates and makefile copied from CD folder
-rw-r--r--english/download/Makefile38
-rw-r--r--english/download/index.wml3
2 files changed, 40 insertions, 1 deletions
diff --git a/english/download/Makefile b/english/download/Makefile
new file mode 100644
index 00000000000..75df8081f9f
--- /dev/null
+++ b/english/download/Makefile
@@ -0,0 +1,38 @@
+# If this makefile is not generic enough to support a translation,
+# please contact debian-www.
+
+WMLBASE=..
+CUR_DIR=download
+SUBS=
+GETTEXTFILES += cdimage.mo
+
+NOGENERICDEP := true
+include $(WMLBASE)/Make.lang
+
+ifeq "$(LANGUAGE)" "en"
+ EXTRAWMLDEP := $(WMLRCDEP) $(GETTEXTDEP) $(TEMPLDIR)/cdimage.wml
+else
+ EXTRAWMLDEP := $(WMLRCDEP) $(GETTEXTDEP) $(TEMPLDIR)/cdimage.wml $(TEMPLDIR)/translation-check.wml
+endif
+
+# The "| $(VCSREVCACHE)" here is an order-only prerequisite - always
+# check that the prerequisite exists and is up to date, but don't
+# rebuild everything whenever it's updated - see
+# https://www.gnu.org/software/make/manual/html_node/Prerequisite-Types.html
+%.$(LANGUAGE).html: %.wml $(EXTRAWMLDEP) | $(VCSREVCACHE)
+ $(WML) $(<F)
+
+ifneq "$(wildcard releases/index.wml)" ""
+RELEASESDEP := releases/index.wml
+else
+RELEASESDEP := $(ENGLISHDIR)/CD/releases/index.wml
+endif
+
+index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/cdimage.wml $(TEMPLDIR)/release_info.wml $(RELEASESDEP) $(GETTEXTDEP)
+ $(WML) $(<F) -I $(ENGLISHDIR)/CD/
+
+misc.$(LANGUAGE).html: misc.wml $(TEMPLDIR)/cdimage.wml $(GETTEXTDEP)
+ $(WML) $(<F)
+
+verify.$(LANGUAGE).html: verify.wml $(TEMPLDIR)/cdimage.wml $(GETTEXTDEP) $(ENGLISHDIR)/CD/CD-keys.data
+ $(WML) $(<F)
diff --git a/english/download/index.wml b/english/download/index.wml
index 68aca8a9d17..3b573717001 100644
--- a/english/download/index.wml
+++ b/english/download/index.wml
@@ -1,4 +1,5 @@
-#use wml::debian::mainpage title="Download Debian"
+#use wml::debian::cdimage title="Download Debian" BARETITLE=true
+#use wml::debian::release_info
<div id="splash">
<h1>Download Debian</h1>

© 2014-2024 Faster IT GmbH | imprint | privacy policy