aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Inggs <ginggs@debian.org>2020-07-03 10:30:24 +0200
committerGraham Inggs <ginggs@debian.org>2020-07-03 10:30:24 +0200
commit39009bc928a187728d51dfd0682553a1b14c831d (patch)
tree52de98fe5a909a185edb44206ed6f8598632e59c
parent0fca57be37ff44f7b32d1018d081d297be989e3a (diff)
downloaddebian_htop-39009bc928a187728d51dfd0682553a1b14c831d.tar.gz
debian_htop-39009bc928a187728d51dfd0682553a1b14c831d.tar.bz2
debian_htop-39009bc928a187728d51dfd0682553a1b14c831d.zip
Close pipe after lsof
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/close-pipe-after-lsof.patch15
-rw-r--r--debian/patches/series1
3 files changed, 17 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 228ed26..3fdce8c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ htop (2.2.0-3) UNRELEASED; urgency=medium
[ Graham Inggs ]
* Switch to debhelper 13
* Avoid FTBFS with GCC 10 (Closes: #957344)
+ * Close pipe after lsof
[ Debian Janitor ]
* Set upstream metadata fields: Bug-Database, Repository, Repository-
diff --git a/debian/patches/close-pipe-after-lsof.patch b/debian/patches/close-pipe-after-lsof.patch
new file mode 100644
index 0000000..e5cbf6f
--- /dev/null
+++ b/debian/patches/close-pipe-after-lsof.patch
@@ -0,0 +1,15 @@
+Description: Close pipe after lsof
+Forwarded: https://github.com/hishamhm/htop/pull/917
+Author: Jesin <Jesin00@gmail.com>
+Last-Update: 2019-06-23
+
+--- a/OpenFilesScreen.c
++++ b/OpenFilesScreen.c
+@@ -124,6 +124,7 @@
+ item->data[cmd] = xStrdup(line + 1);
+ free(line);
+ }
++ fclose(fd);
+ int wstatus;
+ if (waitpid(child, &wstatus, 0) == -1) {
+ pdata->error = 1;
diff --git a/debian/patches/series b/debian/patches/series
index 6bbf748..7cbe4dc 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@
fix-linux-process.patch
python3.patch
gcc10.patch
+close-pipe-after-lsof.patch

© 2014-2024 Faster IT GmbH | imprint | privacy policy