summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <pochu@debian.org>2018-06-19 19:08:30 +0200
committerEmilio Pozuelo Monfort <pochu@debian.org>2018-06-19 19:08:30 +0200
commita9c4d465e50f9d7d1098746bf1a832e0dbfcb31c (patch)
tree6c9f7efc78f66fbb3eb4e6d623e140a6cb87bbd1 /Makefile
parent1e82485267f597aa2535ff5b8de3175f3c450b27 (diff)
Makefile: don't hardcode the python interpreter
The interpreter is defined in the scripts' shebang, so no need to hardcode it here.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 2efe5ef117..3d5e20f0c2 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,3 @@
-PYTHON = python
PYTHON_MODULES = $(wildcard lib/python/*.py)
# The following variables need to be kept up-to-date and can be adjusted
@@ -32,7 +31,7 @@ include lib/*-releases.mk
# <name>_SUBRELEASE: the sub-release identifier for the security tracker
all:
- $(PYTHON) bin/update-db data/security.db
+ bin/update-db data/security.db
clean:
-rm -f data/security.db lib/python/test_security.db
@@ -45,7 +44,7 @@ test check: check-syntax
SYNTAX_STAMPS = $(patsubst %,stamps/%-syntax,$(shell bin/check-syntax --get))
check-syntax: $(SYNTAX_STAMPS)
stamps/%-syntax: data/%/list bin/check-syntax $(PYTHON_MODULES)
- $(PYTHON) bin/check-syntax $* data/$*/list
+ bin/check-syntax $* data/$*/list
touch $@
.PHONY: serve
@@ -65,11 +64,11 @@ update-$(1):
dist="$$($(1)_DIST)"; \
mirror="$$($(1)_MIRROR)"; \
for section in main contrib non-free ; do \
- $$(PYTHON) bin/apt-update-file \
+ bin/apt-update-file \
$$$$mirror/dists/$$$$dist/$$$$section/source/Sources \
data/packages/$$$${prefix}_$$$${section}_Sources ; \
for arch in $$($(1)_ARCHS) ; do \
- $$(PYTHON) bin/apt-update-file \
+ bin/apt-update-file \
$$$$mirror/dists/$$$$dist/$$$$section/binary-$$$$arch/Packages \
data/packages/$$$${prefix}_$$$${section}_$$$${arch}_Packages ; \
done; \
@@ -120,7 +119,7 @@ update-nvd:
wget -q -Odata/nvd/$$name https://nvd.nist.gov/download/$$name || true; \
gzip -f -d data/nvd/$$name || true; \
done
- $(PYTHON) bin/update-nvd data/nvd/nvdcve-*.xml
+ bin/update-nvd data/nvd/nvdcve-*.xml
# Experimental code to compare the Debian and NVD CVE databases using
# CPE values as common key.

© 2014-2024 Faster IT GmbH | imprint | privacy policy